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Introduction

There's not a lot of middle ground when it's about Excel. You've got
customers who enjoy it very much, and you're going to sing the
songs on the spreadsheet all day. On the other hand, you've got the
ones who dislike it. They think it is the software of row and column,
and however, in reality, the advanced Excel theories rely on a
variety of essential skills set that can be used and recognized in
virtually every role in an organization. Since you've familiarized
yourself with these definitions, you must be more informed to:

Visualize, analyze, and assess your data.
Build equations that will enable you to have more details on
critical business functions, including workflow, project
performance, financial forecasts, and budget estimates. It
helps to maintain inventory and consumption levels.
Build a convenient data collection platform that senior
managers can utilize to evaluate ongoing tasks or
conditions in an organization.
Develop spreadsheets that help coordinate details and offer
a better view of the new information.
Interpret and grasp data from the other agencies, suppliers,
and clients.
Provides answers and responses to market issues by
enabling users to view data more sophisticatedly.
Maintain a balance between diverse financial and inventory
records.
Build monitoring mechanisms for various agencies and
activities, with different workflow procedures.
Advanced Excel preparation would supply companies with
highly trained workers. It will also enable employees to help
them function more efficiently in their existing positions and
transition to higher-level positions.



The new MS Excel features (2016 to 2019) are equipped with many
essential features, enabling you to explore the power of excel.

Improving the efficiency and output to render yourself being
an important part of the business
Make you great at data organizing and analyzing
Have the work faster
Greater performance and improved production

To sum up all, it's often said that information is strength, and there's
no easier way to inspire yourself, except developing your abilities
and making your business more valuable through knowledge and
use of technology.



1.1
 

1.2  Versions

 What Is Excel

CHAPTER 1. Understanding the Microsoft Excel

Since the beginning, almost 29 editions of Excel have been released,
starting from 1985 to the present date. Today, most people would
have Excel 2016 edition, 2019 edition, or office 365. Each Excel
edition was drastically different from the last one, just like the Mac
operating system and MS Windows versions are somewhat different
today. Here is a compilation of Microsoft Excel versions.

OS-2 Versions (2.2, 2.3, 3)
Older versions for Windows (2k2, 2k, 97, 95, 3.0 and 2.0)
Older versions for Mac (2k1, 2k, 98, 5, and 4)
Microsoft Excel 2k3 (Windows)
Microsoft Excel 2k4 (Mac)
Microsoft Excel 2k7 (Windows)

TheExcel spreadsheet program can be considered as a series of
columns and rows representing a table. Normally alphabetical
characters are typically allocated to columns, whereas the numbers
are generally assigned to the rows. The position where one column
and a row merge are named a cell. Usually, the address of any cell is
indicated by the letters on top of the columns and the numbers
representing the rows.

MS Excel is a spreadsheet software built for Windows Operating
system, Mac operating system, Android operating system, and iOS by
Microsoft Corporation. It involves estimation, interactive methods, and
pivot tables. It also has a macro programming language named Visual
basic. This chapter of the book intends to offer essential knowledge
about Microsoft Excel 2019 in detail.



Microsoft Excel 2k8 (Mac)
Microsoft Excel 2k10 (Windows)
Microsoft Excel 2k11 (Mac)
Microsoft Excel 2k13 (Windows)

Microsoft Excel 2k16 and MS 365
Microsoft Excel 2k19

It helps users secure their workbooks from unwanted access and
share their details using a code/ password.

The filtering option is a fast and simple way to locate and manage
data within a collection. Only rows that follow the requirements you
define for a column are seen in the filtered list. MS Excel offers
two filtering functions:

AutoFilter, which contains a filter by the option, with
simple parameters

Microsoft Excel helps us to maintain the header section and footer
section in our spreadsheet file.

Excel offers its customers rich functionalities; the end customer can
use the features according to their needs. Below is a collection of
certain common functions that excel claims to offer.

MS Excel helps its user locate the appropriate data (it might be text
or numbers) in your workbook. You can also change the original
data with new data.

1.3  Features

Find & Replace

Data Filtering Feature

File Password Protection

Adding the Header and Footer



Advance filter; used for more specific criteria;

In excel, data sorting is referred to as a method of grouping data in a
sequential way. MS Excel helps users to sort the data in both
ascending and descending order or vice versa.

An Excel file may have different extensions. For the time being, we
are going to cover some of the most popular types:

Microsoft Excel has many tools tailored for various users; for the time
being, we have mentioned some of them, which will be addressed
more in-depth in the next chapters.
SUM: This feature adds all the data values of the cells or a range in
the document.
AVERAGE: In excel, this feature specifies the average values for
data. It determines the total of a range and divides the result on the
number of datasets of the selection.
COUNT: This feature counts the numbers of cells containing
numerical data in the statement. This feature is helpful for the fast
counting of objects in a set.
MAX: This feature defines the greatest value of the cells used in the
selection.
MIN: This feature defines the lowest value of the cell used in the
selection.

Microsoft Excel has many built-in formulas for addition, average,
minimum, maximum, etc. you can use these formulations to fulfill your
needs.

1.4

1.5

 Tools

Data Sorting Commands

 File Types or Extensions

Built-in Formulas for Various Situation s



.XLS
 

.XLSM

.XLSB

.XLSX

How You Can Find the Extension of Any Excel
File

 

This fileextension is the most popular one; it is the default extension
of the spreadsheet that Microsoft Office produces. This extension
was commonly used in versions earlier than MS office 2k7.

Pick anyfileyou like to findtheextensionfor
Now Right-click this File.
A drop-down menu of choices opens.
Select the Properties link in the list. Please refer to the
screenshot given below.

You will have properties window in front of you.
Under the section of file types, you will see file type or file
extension.

This file extension is used for spreadsheet files created with version
2k7 of Excel. The new and latest default extension for an Excel file is
usually XLSX.

An excel 2k7 program creates this extension. This type includes Excel
macro. It's a quick way to know that a certain file holds macros with
the aid of this extension.

In case excel files involve a significant volume of data or details, this
file extension can support you by compressing, saving, and easy
opening functions.



Note: Every file type does not accept all the functionalities
of excel, such as formulas, etc., and then shows a
warning message window. In this situation, you should
change the current format of the file to make it compatible.



2.1
Technology lovers should thankMicrosoft Office fordeveloping

2.2
 

Step 1. Double Click Any XLSX File
 

 How You Can Open Microsoft Excel
 

 Where You Can Get Microsoft Excel
 
Microsoft Excel numerous times because it gives us more relief from
headaches than most pain relievers. This software can easily be
downloaded from Microsoft Official website. Only search google and
follow the appropriate links referring towards Microsoft Official
website.

 

Step 2. Drag and Drop Files into the Excel

CHAPTER 2. Why You Should Learn Microsoft
Excel

If you are trying to open an already saved file, you should follow
these steps before proceeding.

Microsoft Excel is a spreadsheet program. People should learn
Microsoft Excel because it helps to improve. Microsoft Excel is an
easy-to-access software that is a valuable asset in all living conditions
and will be proved crucial for professional growth.

TostartMicrosoft Excel 2019, youshouldgo to Window's Start
menu, select Start All Programs Next Microsoft Office and then select
Microsoft Excel 2019. (Otherwise, write excel after pressing the start
menu button/select the tab) A fresh, blank workbook launch and ready
to insert your details .

Justdouble-click the file to accessXLSX type files in Microsoft
Excel. In case when you have any version of Microsoft Excel already
installed on your device (2016 or greater), the file would be opened
automatically by double-clicking on thefile.



Microsoft Excel toolbar is a row of multiple tabs and icons at the
above Microsoft Excel window, which helps you quickly search,
recognize, and use commands to accomplish a given task. It
seems like a more complicated toolbar than it is. The toolbar first
appeared in Microsoft Excel 2007 to replace the standard
toolbars and pull- down menus used in the previous version of
Microsoft Excel. In Microsoft Excel 2010, Microsoft further added
the option to customize the toolbar.
The Microsoft Excel 2019 toolbar consists of four key components:
sections, groups, launcher dialogs, and the command buttons.

The toolbar tab includes several logically divided
commands into groups.
The toolbar group collects similarly associated commands
performed as a part of a bigger task.
The dialog box launcher is a tiny arrow in the below-right
side of a group that brings up more similar commands. The
dialog box launcher shows in groups that contain more
commands than the existing space.

If any version of Microsoft Excel is already installed on your pc, a
pop-up menu can also help you open the file. With your mouse's
help, right-click the XLSX type file and choose the "Open with"
option. Then this window will offer to open recommended
programs, which will help to open such a file. Click on Microsoft
Excel, and the said file will be open. And if Microsoft Excel is not
found in the list, you have not installed it on your pc.

If Microsoft Excel is already available on your system, then with the
help of a mouse click, you will drag the XLSX type file into the open
spreadsheet of Microsoft Excel. To do this, select the XLSX type
file, hold down the left button of your mouse, drag the file into the
already opened Excel spreadsheet, and release your mouse's
button. By doing so, the XLSX type file is open.

2.3

Step 3. The Open with Right-Click Menu

 Understand Excel Ribbon and Its Elements



The Command button is exactly the button that you click to
complete a certain action.

File: Helps you go the backstage view that includes the
main file-related commands and Microsoft Excel options.
This said tab was added in Microsoft Excel version 2010 to
replace the Office button in Microsoft Excel version 2007. It
was known as the File menu option in earlier editions.
Home: This comprises the most repeatedly used
commands—copy and paste, Sort and filter, formatting, and
others.
Insert: It is used to add various objects in a worksheet—
photos, maps, PivotTables, hyperlinks, special signs,
formulas, and headers/footers.
Draw: It depends on the device you are using; it allows you
to draw your own choice, i.e., a Digital pen with a mouse or
just a finger.
Page Layout: It gives tools to customize the design of the
worksheet of Microsoft Excel, as well as onscreen tabs.
These tools monitor theme configurations, grid lines, page
settings and margins, item orientation, and print fields.
Formulas: This provides resources for adding functions,
specifying names, and managing calculation options as
well.
Data: Hold the entire command to manage the Microsoft
Excel worksheet data and link with the external data.
Review: It helps you correct spelling mistakes, changes in
tracking, add feedback and notes, and secure worksheets
and workbooks of Microsoft Excel.
View: It allows the switching of worksheet views, freeze
panes, viewing and organizing various windows as well.

Standard Excel Ribbon



Help: This tab provides very fast access to the Excel Help
Task Panel and allows you to contact Microsoft
Help/support, submit feedback, recommending some new
features, and get fast access to the training videos.
Developer’s mode: It allows you to access advanced
features—Visual Basic Application macros, Microsoft
ActiveX and Microsoft Form controls, and XML file
commands. This specific tab is hidden, so you need to
activate it first for use. Add-ins: This Setting only appears
when you try to open
an old workbook or launch an add-in that personalizes the
toolbar and menu.

If you launch Microsoft Excel for the first time (by using double-
clicking the icon; otherwise, selecting this from the Start menu), the
program will ask what you want. In case that you want to launch a
new spreadsheet, then click the Blank Workbook tab. Microsoft Excel
will produce a new workbook with one blank sheet.

2.4 Understanding Your Worksheets and
Customize the Work Environment



A selected box will be considered a cell; similarly, the horizontal axis
is rows, and the vertical axis is defined as columns.

The Microsoft Excel structure is built to represent more closely, like
using an excel program or the way people perform the function in
the Microsoft Excel software. The elements of Microsoft Excel have
been mentioned below. The Microsoft Excel interface aims to render
operations and procedures with a Microsoft Excel workbook more
efficiently.
The Live Preview function demonstrates improvements in the
formatting of the frame. You need to move the mouse cursor on the
command to show the format in the window .

Users will configure the working interface by adopting some of the
following settings.

Launch a fresh blank workbook of Microsoft Excel. Then,
customize your blank workbook just as you like it to
be.
A workbook must be saved with a particular file name at
the required location. Further suggestions and more
comprehensive steps are given below.

Options as Font style as well as font-size: Highlight the
sections of any worksheet that you wish to modify, and
also select your choices for number, as well as alignment,
font choices from the Font category, which is at the top of
the worksheet.
In Print Settings: Select one and more worksheets after

Creating an Excel Template

Customizing Excel Work Environment

Some of the Excel Workbook Essentials You
Must Change



Just Right-click for the customization of the ribbon by context menu:

Most Microsoft Excel Ribbon customizations are done in the Design
the Ribbon window. It's a part of Microsoft Excel Options. So, if you
start to customize the ribbon, you need to do one of these things:

then select Page Layout > Page Setting group to specify
print settings, which includes header and footer setting,
page margins, and page orientation, also specify other
print layout preferences.
The worksheets number: You can add and remove
worksheets, also rename sheet tabs as well, and also
change the worksheet tab color. Column size and layout:
Usually, you choose various
column widths, choose the columns or the whole working
sheet and then adjust the said column's width. Gridlines:
You would like to have darker gridlines for every
worksheet. Dark Borders and the grid lines display, and
they do not print. To change the gridline color, select File >
Options > and Advanced. Then, select Display choices for
the current worksheet, after then select the title of the
workbook shown in the list. In the end, under Show
gridlines, choose a different gridline color. NOTE: Every new
worksheet you add to your personalized
default workbook will be restored to the actual formatting
and style. You will choose to apply additional worksheets to
the actual workbook to reserve an additional or main
worksheet that you can copy if you wish.

2.5  Customizing the Ribbon

Go to the File Tab > Select Options > Select the
Customize Ribbon

How You Can Create New Tabs for Adding In a



2.6
On-PageLayout SettingtabinMicrosoftExcel,select Colors and

Ribbon

 Setting the Colors of the Theme
 

Creating Your Very Own Colors Theme
 

choose the color you like.

For making your preferred commands quickly accessible, you may
insert your particular tab into the Microsoft Excel ribbon. Here is
how:
Go to the Customize Setting and then Ribbon window, select bottom
list of tabs, then click the New Tab Icon .
This will insert a custom tab into a custom group, so commands may
only be adding to a custom group. Pick a recently created tab, called
Fresh Tab (Custom), and press the Rename button to assign your
tab's proper name. In the same way, adjust the default name
provided by Microsoft Excel into a custom group and further
comprehensive instructions. When you're finished, press OK to save
updates.

Onthe MicrosoftExcelPage Layoutsetting tab and the
Design setting Tab, Click on Colors, and then select
Customize Colors.
Press the button, which is the next button to the theme
color you wish to adjust (e.g., Accent 1 and Hyperlink), and
then select a good color for Colors' theme.

For making your color theme, select More Colors, choose a
color based on the Regular tab, insert color code numbers,
or choose a color from the Customized tab.
The sample pane is used for preview and the changes



which you made.
You can also repeat this practice for these colors you like to
modify.
For Name Box, write a Name that you want for the fresh
theme of colors, and click the save button.

Proof configurations modify how Microsoft Excel make corrections
and format the text when you write—this function lets you pick the
settings that are used to make correction of text automatically at
the same time when you type, and to store and reuse the text and
other objects that you use often. Just select the AutoCorrect
Options, and

On the Microsoft Excel toolbar, first, you may go to the Formulas
icon> Mention as Calculation group, then click the Calculation Options
icon, and choose the following choices:

Automatic (default): Guides Microsoft Excel to
automatically recheck all the dependent formulas for any
given value, formula, and name referred to in such
formulas.
Excluding the Data Tables automatically: Automatically
recheck all the dependent formulas excluding data tables.

Remember not to confuse Microsoft Excel Tables (i.e., Insert >
Table) as well as Data Tables that estimate various formula values
(Data > What-If Study > Data Table). This option prevents automatic
recalculation just for the data tables, and standard Microsoft Excel
tables will always be automatically calculated.

Manual: Turns off the automated calculation in Microsoft
Excel. Open workbooks can only be rechecking when you
specifically use one of these approaches.

2.7

2.8  Proofing Settings

 Setting Your Formulas



then pick the option which you like.

Here's a collection of quality standards for developing Microsoft Excel
spreadsheets. They can allow you to function better and generate
organized data, but you must follow them.

Worksheet Creation: Keeping relevant data within one tab

Ignoring words in UPPERCASE: Microsoft Excel ignores
words written in UPPERCASE letters in a spelling check
process.
Ignoring words containing numbers: Microsoft Excel
ignores the specific words that include numbers in a
spelling check.
Ignoring Internet addresses and file addresses: You can
select this check box in case you want Microsoft Word to
Miss automatically Internet addresses, as well as file
names, also e-mail addresses.
Flag repeated words: Identifies and labels words that are
repetitive during a spelling check
Enforce the accented uppercase: For French content, it
shows accentuated uppercase characters.
Custom Dictionaries: You have to click this button to pick
the dictionary you wish to use while checking the spelling.
French modes: In Dictionary, set spelling rules for the
pronunciation of French words. Choose the option which
you want to remain in the said list box.
Spanish modes: You have to set rules of spelling for the
Spanish words. Choose the specific option which you won't
remain in the said list box.
Dictionary language: It allows users to set the language
of the dictionary which they wish to use.

2.9  Best Guidelines to Work with Excel



allowed you to utilize Pivot Tables, the functions, Subtotals,
and the Worksheet Formulas.
Data Layout: The Viewers usually scan the columns and
the rows to understand the data's organization. By first
identifying and displaying the most actual information,
viewers can continue to manage and analyze data more
easily. Improved Performance: Some large workbooks
have
better total performance than a smaller group of connected
workbooks. Data Validation Function: Every method that
can help
remove errors is a time-saving function that can maintain
the data correctly. You have to find this feature in the Data
tab from the Data Tools group.
Absolute References: You need to retain the reference of
said cell and the same while copying and using AutoFill?
Simply utilize the "$" symbol to prevent automatic material
adjustments.
Protect your cells: It is used to protect important and
private cells and ranges by specifying which users are
permitted to perform edit or formatting tasks as well.
Advantage of using color: The usage of color is a perfect
way to highlight your important information and offer
readers a break while reading a huge amount of data. You
have to use different color options present in Conditional
Formatting, Cell Types, and the regular color options.
Summary Sheets: Make a named range to group the total
from each sheet that you wish to make a summary from. If
you want to summarize the said total sheet, choose the
named range by going on the feature menu.
Using Cell Merge Alternative: If you make sorting simpler,
go through the Format Cells, choose Orientation, and by
horizontal drop-down, will use Center Through Range to



center a mark across several cells. Mark for simple
calculation: When you exchange and
make formulas, mark the ranges and set the formulas a
detailed name. Doing so would make it easy to pick vast
data quantities and make it easier to understand the
different formula's intent.



3.1
Microsoft Excel utilizes the standard operators specificallyfor

Creating a Simple Formula Example in Excel
 

CHAPTER 3. Basic Formulas and Making
Calculations in Excel

 How You Should Enter Formulas in Excel
 

Every formula, as well as functions of Microsoft Excel, are bread and
butter. For both, you will feel everything more impressive and useful,
and you will also enjoy doing something in a spreadsheet. This
chapter presents the basic principles you need to understand to be
confident while utilizing these formulas in Microsoft Excel.

Choose thecell atwhich theanswerappears(B4,shownexample).

Type a symbol equivalent (=).
Type formula which you wish Microsoft Excel to calculate (e.g.,
75/250) .

By Pressing Enter. The specific formula will finish the calculation,
and the result will be seen in the said cell.

When the figures of a result of the formula are big in a cell, and it
appears as a hash (#) rather than a value, it indicates that the
columns are not large to show the cell's value. Now you have to
manually increase the column's width to show the contents of the

equations, i.e., a plus sign for sum (+), the minus sign for negation
(-), the asterisk sign for multiplication (*), front slashing for division
(/), and the caret (^) for exponents. There is the main point: in
writing Microsoft Excel formulas, you must begin formulas with an
equal symbol (=). This is necessary because the cell includes, or is
equivalent to, the formula and its value.



cells.
3.2 

The reference of a cell address is always a variation of some column's
letter and a row number that classify a cell in a worksheet. During the
creation of cell reference at a similar sheet, the following points must
be considered.
First, select the cell where you want to insert the formula. Now Type
the symbol (=). And now follow these steps:

Now you want to type the accurate reference in the said
cell or in the top bar called formula bar.
Select the appropriate cell to which you wish to refer.
Type the remaining formula and then press Enter for
finishing.
For example, for adding the value in a cell A1 and A2, you
must type this = sign, and click A1, and then type this +
sign, then click A2 and then press Enter:

If you want to make a range reference in Microsoft Excel,
select the required cells on a specific worksheet.
For example, for adding the different values in cells A1& A2
or A3, then type an equal symbol followed as the name of
SUM method and the starting parenthesis, and then select
the cells with A1to A3, and type the ending parenthesis,
now press Enter:

For granting the reference of the complete row or complete
column, tap on the row number; otherwise, refer to the
column letter. For example, to merge all cells in a single row,
start to type
the SUM method. Now click the first Header of a row to

Creating the Formulas Which Refer to the
Other Cell Inside the Same Worksheet



indulge the reference row within your formula.

Making Links or other external cell references may be used to avoid
the same data in different sheets. Which saves time, decreases
error, and increases data integrity. Conduct the following measures
to make an external reference:

First, Open all of the workbooks
Select the workbook named "Company" and choose cell
B2, then type an equal symbol =

At View Tab, on window group, select Switch windows.

Now Click the workbook "North."
Pick cell B2 in the said workbook.

Now type a +
Then Repeat the steps from 3 to 6 for your "Mid"
Workbook.
Now, Replicate measures from 3 to 5 for your workbook of
the South.
Finally, delete the $ signs in the cell B2 formula for further
proceeding.

Results:

3.3 Create a Formula That Links to the Other
Workbooks



3.4 Use of Apostrophes for Enclosing and to
Full the File Name and the Worksheet Name

 By Using theINDIRECTmethodof Excel, you canchange atext
string for correct reference. You may utilize the & operator to make a
text series.

Take a look at the INDIRECT method mentioned below, i.e.

Justification: =INDIRECT(A1) is shortened to (sign) =INDIRECT
("D1"), and the INDIRECT method change the text string "D1" as a
correct cell reference, and in other terms, =INDIRECT("D1") is
shortened to =D1.

The basic INDIRECT function mentioned below achieves
almost a similar result.

Do we still need the role of the INDIRECT? Yeah, yeah.
Without the usage of the INDIRECT method, this will be the
outcome.

The use of & operator links the "D" string along with the
value in cell A1.



4.1
Normallyan active cell is a rectangular cube, whichshows the cells

4.2  Putting an Excel Cell in Editing Mode

 Active Cell and How You Can Activate It
 

CHAPTER 4. How You Can Select and Activate or
Edit Cells in Your Excel Workbook

Selecting, triggering, and making cell changes are the most common
functions that someone may use in the Microsoft Excel worksheet. As
a Microsoft Excel user, anyone must be able to trigger a cell and keep
it working when you insert the data into it. To get an activated cell
address, you need to enable it first. Although not everybody knows
what an activated cell is. So, we're going to start there.

in Microsoft Excel. This helps us highlight the cell we are operating
on and where the data entered. The active cell is often referred to
as the cell pointer, the current cell, or the selected cell.

Any Microsoft Excel user can tell the difference between the active
cell, and it is in the edit mode. It is also important to learn how we
made a cell active. Clicking on a cell indicates that you are going to
activate it. You'll see
a green and grey boundary across it. Active cell indicates that it's
fully ready to be transferred to edit mode. In short, we'll see how to
put a cell to the edit mode.

We can change the said active cell by moving the mouse cursor and
select another cell simply using the Down arrow Key, Up arrow Key,
or Left arrow Key and Right arrow keys. As soon as you click the
Enter key, the active cell row will go down, and if you make any
changes to that said cell, you will have to pick it one more time
manually before you put it in the editing mode.



In the 2013-2019 versions of excel, these editions wrap the active
cell along a dark border to recognize the cell where you are
editing. Click the Enter key after the cell becomes an active cell
towards the next cell. In case you are evaluating the impact of
modifications in the authentic cell value, this change makes you
step back until you adjust the value again. Even so, Microsoft
Excel makes you disable such movement, and you retain the said
cell-active unless you adjust its position manually.

Press the "File" tab and choose "Options."
At the left side of Microsoft Excel Options, press
"Advanced."
Uncheck "After click Enter, Shift Selection" in the Edit
Options area.
Select "OK"

Suppose you press the key "F2" in any Microsoft Excel cell. In that
case, the current mode will be converted to "Edit" mode, and when
you press double-click at non-blank (in which the data has already
been entered) Microsoft Excel Cell with the help of the mouse
pointer, then the Cell mode change to the "Editing" mode.
As far as you are in "Editing" Cell mode, clicking the navigation keys
would not convert the Active Cell to another cell. In "Editing" mode,
move left or right with arrow buttons will allow the text cursor to shift
from left or right inside the cell towards the arrow key, and the up
and down arrow has zero impact on "Editing" mode .

While using the "Enter" mode, you also convert to "Editing" mode
with the help of the "F2" function key. You can easily move between
"Enter" and "Editing" mode by pressing the "F2" key. While in "Enter"
mode, pressing every Arrow key would make the existing cell lose
the focus, same as in an Active Cell. Then the next cell would be the
Active Cell, towards the direction of the Arrow key.

4.3  How You Can Keep a Cell in Active Mode



4.4  Returning to an Active Cell
Some spreadsheets are wide and extend far beyond the upper and
lower sides of the computer display. There are also several
methods to navigate through a wide spreadsheet, but moving up
and down and lose focus from the active cell is very normal. A
normal scroll up or down would get you to return to where you were
earlier—to the active cell. In a wide sheet, it is very difficult to return
towards an active cell. Mostly, you did not remember the active
cell's directions; however, it depends on how long you've wandered.
Scroll back towards the active cell is the least systematic way to get
there.
If you remembered the active cell, you should press [Ctrl]+G, enter
the said cell address and range name, and then click OK. More
definitely, you forget the cell reference, but it's OK because a
keyboard shortcut key will help you to go back towards the active cell
—from everywhere on a similar sheet. Once you've lost sight of the
said active cell, you may use [Ctrl] along with [Backspace], and
Microsoft Excel will go back towards the active cell.



5.1

5.2

 Use of Find Function
 

 Use of Replace Function in Excel

CHAPTER 5. Use of Finding or Replace Functions
in Excel

The method of finding and replacing function in Microsoft Excel uses
to find things in your workbook, including a certain quantity or text
string. Further, you can find the search object for reference, and you
can also change it with another. You can also use wildcard symbols
like question marks and asterisks, and numbers in your finding terms.
You can easily search rows and columns, search inside comments or
values, and find inside the worksheet or whole workbook. You can
easily search rows as well as columns, search inside the comments.

Tostart with this, choosethe entire range of cells to look
inside the workbook. To search over the whole worksheet,
select any cell on the currently active sheet.
Open your Excel and click the Find and Replace option by
clicking the Ctrl and F button simultaneously.

Inside the find box, Insert the characters (Words or
numbers), and if you are seeking all words, click "find all";
otherwise, find next.

Once you press Find Next, Microsoft Excel will pick the
search's existing word inside a document. The second click
will select the second existing word, etc. When you press
Find All, Microsoft Excel would access a list of complete
events, so you can click every object in the collection to
navigate with the analogous cell.



With the help of wildcard characters during your search, you can
easily automate several finds and replace task in Microsoft Excel:
Using an asterisk (*) wildcard to find a chain of characters. For, e.g.,
sm* would find "smile" and also "smell" Use the query mark (?) for
finding a particular character. For example, gray will find "Gray" and
"Grey."
Let suppose if you want to find a list of words that begins with "ad,"
you will use "ad*" for your search criteria. Here is an important thing
that you must consider and remember, that with its default options,
Microsoft Excel will search only for the criteria everywhere in a cell. It
would back all these cells that already have "ad" in any shape in

To replace some Microsoft Excel characters, which may be the text or
numbers, you should use Microsoft Replacement feature. The detailed
steps are given below.

Choose a range of the cells where you wish to replace the
text or numbers. To replace the character(s) of the whole
worksheet, you may click at any cell on the currently active
sheet. Ctrl + H is a shortcut command of a keyboard that
will help you in the opening of the find and replace dialog.
Instead, go to Home setting > then go to Editing group, and
press find & Select > then replace.

If you have just used Microsoft Excel, find the tool. Turn
towards replacing tab.
Now you see the two boxes, type within the replace dialog;
the first one is the Find box wherein you type the value you
want to search, and the second one is where you type the
value you want to replace.
Finally, it depends on replacing the existing value, or click
on Replace All for replacing entire values in one click.

Use of Wildcards in Find and Replace Function s



other circumstances. To avoid this form of a situation from occurring,
press the Options icon, and search the Match whole cell content box.
Then this will force Microsoft Excel to return only the values starting
with "ad," as seen in the following screenshot.

If you want to find the real asterisks or query marks in your Microsoft
Excel worksheet, you should type the tilde symbol (~) before them.
For example, if you want to find those cells with asterisks, you would
write ~* within the Find What box. Use~ to find those cells that
include query marks? As per your search condition.
This is the way how you can easily replace entire question marks (?)
inside the worksheet with one or another value (which is number one
in this example):



6.1
Thisispresumably somethingyou didin the past. This is extremely 

 Create a Blank Workbook
 

6.2 Creating a Template for Opening a
Workbook From the Excel Template

 

CHAPTER 6. Creating and Managing Workbooks
or Worksheets

Ifyou're savinga workbook toatemplateforthefirsttime, start by
setting the default personal templates location:

In MS-Excel, a workbook is a series of several spreadsheets known
as worksheets, and the spreadsheets reside in one File. You can
take an example of an excel spreadsheet with a screenshot below. It
is a component of an Excel file. This File is entitled "Book1." This
File includes two sheets. The first sheet is called "Sheet1," whereas
the second sheet is called "Sheet2."

easy.
Once you open Microsoft Excel, you can see a window that
asks what you wish to do:

To open a fresh workbook, press the double-click on a
blank workbook, and you are able to go. That's all.
If the workbook is already open, press the file tab starting
from the left position of the ribbon, then you should choose
the "new" one from the upper left sidebar.

Press Double-click on the fresh workbook again.



And if you save a workbook into a template for the very first time,
start by setting the default of your personal templates point:

Press the File > Options tab.
Press Save, then press Save a Workbook.
Usually this way is: C:\Users\then [UserName] Documents
& Custom Office Templates.

Press OK.
If this Setting is done, all the custom templates which you
save in the My Templates file will automatically show up
within the Personal File on the New page (File > New)

This is the method for Opening a workbook from a template:
Tap the File > New.

Press the Personal tab
Now Double-click the template you've just made.
Here Microsoft Excel makes a fresh workbook based on
the template.

For opening an already saved workbook in Microsoft Excel
2019, click the FILE tab on the toolbar at the top of the
main screen.

Now press "open," which is on the left side. Then you will
see "Recent Workbooks," which are listed on the right side.
For the quickly opening of these workbooks, press on the
specific workbook name under "Recent Workbooks."

6.3  Open an Already Existing Workbook



Choose from Sample templates, and these are simple
templates that are already installed on your pc.
Look towards under com Templates group, click on any
category to see the thumbnails, and then download the
specific template you like.

Or even if you could not find a workbook from the "Recent
Workbooks" tab, click on the Computer tab and select the
Browse icon.
This will open a window where you can search the
Microsoft Excel workbook. Highlight a specific file that you
want to open, after then press the Open icon. In this case,
we are going to open a workbook file named
tech on the net 2013.xlsx.

Microsoft Excel will open the current workbook.
In case you wish to open any file quickly in Microsoft Excel,
you should double click on the File by mouse to open it
quickly; otherwise, you also open the specific File by using
a right-click on a said file.

A Number of a tremendous chain of free templates of Microsoft Excel
are ready to be used. Take the following steps to create a new
workbook file based on the Excel template.

In Microsoft Excel 2019, go to the Excel File, then click
new, and you see many templates that Microsoft Excel
provides.

6.4  A Business Example

For Excel 2010 Version You Can Use 
Following

the



Just click on the said File, then press open with, and then
press the word (on desktop)

At the already Open page in the backstage screen, you will
navigate to the said file location.
In the dialog box, inside the file type having a collection on
the right side of the File box, select All files to view all files
inside a folder, or select the particular file category you
wish to find.

The native File is the electronic File's file layout as specified in the
application generated by excel. Thus, e.g., if a spreadsheet of
Excel is created, then that native format of the document is the
original Microsoft Excel format (.xls).
Even so, in Microsoft Excel, you can open non-native files also.

If you want to preview any template, just press it. A sample
of the chosen template will appear with its publisher's full
name, further information, and a guide about how to work in
this template.
If you'd like a preview of the template, press the Create
button for downloading. For, e.g., you have chosen a good
calendar template for Microsoft Excel:

This is the template that you chose, and it will be
downloaded quickly, and a fresh workbook will be created
automatically, which is based on this template.

6.5  Native or Non-Native Files in Excel

To Open a Non-Native File Inside Microsoft Word
2013 From the File Explorer

Opening of a Non-Native File in Microsoft Word
2013 by the Program Window



Select the required File that you want to open by the Open
dialog window, then press the open icon.

To import the data from any external resources, Microsoft Excel
allows its user the freedom to get the data from multiple resources,
including.

Access of database
The webpages
The text files
By other workbooks

Now, we're going to talk about how you can easily import the data
from an external file.
In case you have the data in the txt file, CSV file, or text files, you
can easily import the data from certain directories that are treating
with them like text files. For doing this, take the measures given
below:

First, open a new Microsoft Excel Worksheet.
Secondly, press the Data tab located at the Ribbon bar.
Press from Text for Getting Outer Data Group. Then the
Import File dialog appears.

Then you will see the print file, txt file, and CSV file
approved extensions.
Select the specific File. The name of the chosen file occurs
inside the File Name box. Now the open icon turns into the
Import button.

Press the Import button. Then the Text Import Wizard
window will appear.

6.6  Connecting Excel With External Sources



Click the options Delimited to select the file type, and then
click Next.

Pick Other under Delimiters.
Just type inside the box next to the other | (This is the
delimiter in the shape of the text file you are trying to
importing).
Press the next icon.

You will configure the data of column format for each
column in this dialog window.

After completing the formatting of data columns, press
finish, the Import Data dialog box will appear.

You can observe the following:
A grayed table is displayed for chosen. In this situation, you
have a single option, which is a table for viewing.
You can insert your data in a fresh file or either in an
already saved file.
You may select the said check box and insert the relevant
data into the Model of Data.
Press OK after completed.

The data will appear on the specified worksheet. You've imported
data in Microsoft Excel workbook from the Text file.

There is a list of some operations of the Common Excel worksheet,
which can be used by beginners and small business holders also.

6.7  Worksheet Operations

Removing Columns or Rows



To select all sections, just select 

Select the column and row header to choose the whole column and
row to be erased. Right-click on every cell, making outlined row and
column. Then click delete from the menu.

Tap the column header at that place where you wish to add a fresh
column. Press Right-click button on any cell will make the column
highlighted. Press the insert option from the main menu.

Press long the CTRL key, and then click the left one quote key (this
key normally has a "tilde" (~) sign). Repeat this procedure to switch
back to the numeric view. Note: This spreadsheet data may be
printed either on the formula display and the numerical display.

the column header. Press Right-

To select the whole worksheet tab on the gray rectangle in the center
of the "A" column header and the "1" row header, which is on the
upper left side of the Excel spreadsheet. Select the data by the menu
bar, after then sort. For sort by, pick the column to be sorted by, and
choose either ascending or descendin g

Tap the row header at that place where you wish to add a fresh row.
Press Right-click button on any cell will make the row highlighted.
Press the insert option from the main menu.

Select the specific cell where you want to insert the formula, and
then enter the formula. As a note, formulas must start with an
equal symbol; (=). Additional details regarding the functions can
be easily accessed by just clicking on the equal symbol (=); this
is mentioned in the formula bar.

Sorting

Formulas

Adding a Row

Adding a Column

To Change the Column Width

Show Formulas in the Entire Worksheet



click at any cell in the marked column, click "Column Width to..." from
the main menu, insert a required value for the width of the column. As
a note, different column widths may be changed simultaneously by
choosing several columns at once.

For highlighting the whole section, tap the row header—Press Right-
click at any cell on the highlighted lines. Select the Row Height tab
from the main menu, set a value required for the adjustment of row
height. As a note, different row heights may be changed
simultaneously by choosing several rows at once.

Choose the cell(s), column(s) and row(s) by highlighting. Just Right-
click at any cell which is highlighted. Click the Copy tab. The chosen

To highlight the whole column or row, just tap on the column and row
headings. Select the Justification tab for (either left justify, middle or
right justify) from the Formatting Toolbar. Remember, these three
keys are easily found on the right side of the bold, italics, and
underline keys.

Please click on the cell. Select the Justification icon (either left justify,
middle or right justify) at the Formatting Toolbar. Remember, all three
keys will be seen on the bold, italics, and highlighted buttons on the
right side.

Select and move the cells that contain the numeric data—Right-click
at any cell to the highlighted field. Select the Format cells. Tap to the
Number tab and pick Category for the form of data inside cells.
Remember, for the adjustment of the figures of decimal places inside
numerical data, pick a number and insert the figures of decimal
places to use.

Adjusting Height for Rows

Copying Cells Columns and Rows

Justification of the Columns and Row

For the Justification of the Cell Content s

Adjustment of the Numerical Data Format



A Formula = (5*3-4^2) is calculated as-1.
A formula = 5*(3-4) ^2 is evaluated like 5 (do it yourself)

Choose the cell(s), the column(s), and row(s) you wish to paste
recently copied data (i.e., of Windows clipboard). Remember, the
chosen area would be the same in size as the data as you paste—
Right-click at any cell which is highlighted. Then Click the Paste tab.

cells will be copied (in a transparent way) on the Windows clipboard.
Remember, the windows clipboard only keeps the last copy data.

For the adjustment of the color of the Worksheet tab in Microsoft
Excel, pick the Worksheet tab which color of the tab you wish to
change

At the ribbon, press the "Home" key.
Now press the "Format" key on the "Cells" category key.
Roll the pointer down towards the "tab color" control.

Microsoft Excel always observes the rule of arithmetic precedence
during evaluating formulas.

 The operations enclosed with the parentheses shall be evaluated
first; the nested parentheses shall be evaluated from inside to out.

 exponentiation
 The multiplication and division method, calculated from left to

right side

 The addition and subtraction, calculated from the left to right
sid e
Example:

6.8

Arithmetic Precedence Rules

 Excel Worksheet Operations

Pasting of Cells Columns and Sections

()

^
* and /

+ and -



In the main menu bar, select the color you wish to add to
the worksheet page.
Instead, for opening the "Colors" dialog window to choose a
color, press the "More Colors..." menu button.
Instead, to delete a color inside the chosen worksheet tab,
tab the "Nil Color" menu choice.
To display the array of colors that you have created more
specifically, deselect the chosen worksheet tab.

In case you want to see only one or two invisible sheets, here is the
method how you can unhide them:

Just Right-click on any sheet, then select unhide by context
menu tab of your Microsoft Excel.
Pick any hidden sheet you want to show at in the Unhide
box and then press OK (otherwise, double-click the said
sheet name), then it is done!

In addition to the background menu with the right tap, from
the ribbon, you will reach the Unhide dialog box:
In Microsoft Excel 2003 or earlier, select the menu Format,
and then select File > Unhide.
Go to the Home menu in Microsoft Excel 2007, Microsoft
Excel 2010, Microsoft Excel 2013, and Microsoft Excel
2017 > group of Cells, press Format, the point is to Hide &
Unhide, after then click Unhide...

6.9

6.10 Going to the Named Box

 Hiding/Unhiding the Excel Worksheet



Workbook Theme helps to offer your workbook in unique feel and

Name Window displays the working cell address. For, e.g.,
if you have chosen the C1 cell, the working cell address
would be displayed as C1 in the name box.

The first case in Microsoft excel is where we were dealing
in excel. We click another key on the screen, the working
cell is missing, and we don't realize what the current cell is
anymore.

Choose the cell block. In the snapshot below, we pressed enter after
typing B100 in the name box. This picks a set of cells, and you don't
have to move your cursor over your workbook.

The Microsoft Excel HYPERLINK feature returns back a hyperlink
from the said destination, the "friendly name." You may use
HYPERLINK to create a clickable hyperlink using a formula.
HYPERLINK role will link to workbook places, internet sites, or
network server data. Now take an example below.

Type"=hyperlink 
[http://example.microsoft.com/report/budget
report.xlsx]Annual!F10" for any cell, [file])"

("

It will make a hyperlink to the cell F10 within in Annual
Excel Worksheet in the workbook, which is saved at
http://example.microsoft.com/report. The cells on the
worksheet that includes the hyperlink show up the content
of cells D1 like the jump text.

Using Go to Function

6.11 What are the Hyperlinks

6.12 Modify Theme for the Workbook



look.
Select the Layout tab.
Press the theme tab. Small 
theme appearance.
Pick a theme.

First, Go to the Layout tab.
Then select colors from the Themes portion.
Pick Customize Colors.

Now Change the colors of your favorite palette from the
pop-up pane.

Remember to press the Save tab while renaming the
theme.

thumbnails display a single

We always face a problem where the columns covered the whole
page and 1 column still does not fit on a page, then the said
document move to another page. To fix this problem, we need to
use the margins / Ruler /options in the Microsoft Excel Page
Layout tab.Now Press the Microsoft Excel Page Layout tab. Then you

can see a variety of operations accessible, each of these
consists of many choices.

Press on the "Margins" tab under "Page Layout," and you
will see various margin choices. Ideally, there are four of
them— Final Custom Settings, Standard, Broad, and Small
margins. You should pick anyone according to your needs.

6.13 Modify the Page Setup

Defining a Fresh Custom Theme



Choose a row and a heading under where you wish the new row
will appear. For, e.g., if you choose to add a new row among
rows 7 to 8, choose row 8.

Now click the add command on the Home page.
The fresh row appears above the chosen row.

Press on "Narrow" margins. They are narrow down margins;
they also provide more capacity to obtain the columns.
To adjust the style, go to "Page Layout" settings and click
the Orientation button next to the Margins icon.

You may also adjust the height of the paper to get a good printing
page. Then go to the "Page Layout" setting and press the "Size"
button below. This option helps you adjust the paper size of that
document before it is ready to print.
If the data is huge, it has a vast number of rows (assume 10,000), it
won't fit on a single page anyway. It's going to go on several pages.
The biggest issue is that the column names are only available on the
first side. So, what about the other pages where the data will
populate? It's going to be hectic to determine which column belongs
for what. Consequently, having column names of a single page is
necessary when setting the page.

Tap the "Page Layout" tab, then go to the "Print Titles"
button. Select that icon.
As quick as you press the "Print Titles" icon, a fresh "Page
Setup" window opens up whereby the "Sheet" option is
enabled (Because you choose Print Titles)

6.14 Inserting and Removing Columns and Rows
For Inserting Rows



Deleting Column

For Deleting Rows
 

6.15 Adjusting the Row Height as Well as Column
Width

Column Width
 

Pick the column(s) you wish to remove. In this case, we're
going to pick column E.
Press the Delete command, which is on the Home page.
The chosen column(s) will be removed, and the columns
on the right side will be shifted to the left side. Column F
is called Column E in this case.

Pick therow(s) as well as the column you wish to erase. In this case,
we're going to pick rows 6 to 8.

Press the Delete button, which is on the Home page.
The chosen row(s) will be removed, and the row(s) under
will be moved up. In this case, rows 9 to 11 are rows 6 to 8.

Placethe cursoron the columnlineatthecolumnheading;
this cross became the double arrow.

Press and pull the column from the right side to maximize
the width of the column and from the left to reduce the
width of the column.

Release the mouse. Now the width of the column will be
adjusted easily in your spreadsheet.



Begin by selecting columns and rows that you wish to hide. You can
easily do this in a couple of different forms mentioned below.

To select several adjacent columns and rows, choose the
first column and row, press the Shift key button long, and
then select the last column and row.
To select several non-adjacent columns and rows, press
the first column and row, press the Control key long (which
is Command on Mac), then click the other columns and
rows.
To use the name box, write a cell name inside the name

Place the cursor along the row line so that the white cross
shows a double arrow

Press and move the row down to raise the height of the row
and up to reduce the height.

Release the mouse. The worksheet will adjust the height of
every chosen line.

Remember, If you see these pound signs (#######) inside a cell, it
means the said column is not vast enough to show the cell data.
Simply extend the width of the column to display the content of the
cells.

Modifying Row Height

6.16 Hide and Unhide Rows and Columns in the
Worksheet



First, go to the Insert > Text Group, then press the Header
& the Footer icon. The worksheet would be changed into

Just Right-click the slim double line that shows the hidden
row and column. Now click Unhide.
Choose the two columns and rows in the nearby place. On
the Cell Group of Home tab, click Format, Hide and
Unhide, and then select either Unhide Rows or Unhide
Columns.
To unhide entire columns and rows in the spreadsheet,
select all the rows by using the Key "Control" along with the
"A" key (Command along with A on a computer) keyboard
shortcut. Just right-click, and choose Unhide

box on the left side of the formula area. E.g., if you wish to
hide the 2nd row, which is type B2.
If you have made your selections, then follow these two
ways to hide the columns and rows.
Just Right-click on the column and row you wish to hide,
then choose Hide. (This way will not work if you have typed
in the said column or row identifier.)
Press the Home tab, click format> Hide and Unhide inside
the Cells group, and choose whether Hide Rows and Hide
Columns.

When the column or row is hidden, you will see a slim
double row showing where the hidden column or row is
placed.

6.17 Add and Customize Header and Footer

How You Can Unhide the Columns or Rows from
Excel



the Page Layout Format.

Here you can type text, add an image, apply a preset
header and special elements to each of the 3 header
boxes, which are at the top of the screen. The central box
is chosen by default:

In case you want the header to show at the top left and the
top right side of the page, press the left or press the right
box and type any detail there.
When completed, click wherever on the said worksheet to
exit the header field. Click Esc to leave the header box
despite retaining the changes.
As you wish to print out your worksheet, then the Header
would be displayed on each sheet.

From the Insert tab, press the Header and Footer button
inside Text Group.
In the Design tab, select Go to Footer; otherwise, navigate
down toward the footer box at the end of the said page

Press the left, middle, and right-footer box, depends on the
position you choose, and then type any text and insert the
data you want. To insert a default footer, then please follow
these measures to create a custom Microsoft Excel footer.
Now see these instructions. When it's completed, click
wherever on the specific
worksheet to leave the footer field.
E.g., add page numbers under the worksheet, select one of
the footer areas, and then click on the Template tab inside
the Header and Footer group.

To Insert the Footer



 

Customize the Errors
 

Customize the Header and Footer

6.18 Warning Messages and Data Validation
 

To easily change the font type or font color of the header as
well as footer, pick the text along with the appropriate
formatting setting in the pop-up box.

Instead, pick the text header and the footer you wish to
modify. First, go to Home, Font group, and choose the
format choices required.

Recognitionof the Dataiscarried out using the Microsoft Excel user
interface rules on the ribbon data tab.

The Data validation has specified a window with three tabs:

Datavalidation is the feature in Microsoft Excel used to monitor what
a user will insert in a cell. For example, you might use the data
validation to ensure that a number is between 1 and 6, ensure that the
date occurs during the upcoming 30 days, and otherwise ensure that
a text entry is smaller than twenty-five characters.
Data validation will show a message to the users that inform them
what is accessible, as seen below.

The validation of data will also ignore invalid user input.
Here's an example: If a code of any product is unread or
fails to validate, you can show any desired message.
Further, the data validation will be utilized to present the
user along with a predefined option inside the drop-down
menu also:

This would be a simple method to give the user the same values that
fulfill theneeds.



The steps you need to follow to enable the Developer tab seem to be
super quick.

We need to right-click at any of the current tabs which are
on our ribbon.
This unlocks the Options menu. Then we need to use
Customize the Ribbon also.

Then pick the Developer checkbox and press the OK icon.

The Developer is tab available now.

Settings, Input Message, and Error Warning.

The Input Message option defines the message to be shown when a
validation rule cell is chosen. This Feedback Message is entirely
optional. In case when no input message is placed, no message may
show.

The Error Message Tab monitors how validation is
implemented. For example, when the design is configured
to "Stop," invalid data causes a message window, then the
input is not enabled.

Click Macro security on the Developer tab, which is in the
Code Group.

To activate the Developer tab, also see the display
Developer tab

6.19 Enabling the Developer Tab

6.20 Macro Recording and the Security Option



Now click the choice that you wish to be in the Macro
Setting tab.
Recording the Macro

When you upgrade to a new edition of Microsoft Excel, and you know
that you're exchanging workbooks with others who haven't

The Macro Record feature works the same with all new versions of
Microsoft Excel: 2010, then 2013, then 2016, and current ones.

Just click on the Macros command of the Display section
inside the Macros group.

Just Press the Record Macro tab.

1. Enter the name of the macro. Choose a different name that
defines the macro specifically. You could not be utilizing
spaces for the name.
2. Press a key for the shortcut. Then you'll be able to execute

the macro using this shortcut key.
3. You can choose where you want to store these macros.

Normally, you can accept its default value.
4. Enter a short text to simply clarify what the macro does.
5. Select OK now.

Remember, every keystroke is recorded after pressing OK.
To stop the recording, press the Macros command on the
Macros group's Display tab, then select Stop Recording.

6.21 Backward Compatibility

Macro Record Dialog Window



You may go back to the standard view at any moment.

Microsoft Excel provides three sample workbooks, Standard, Page
Layout, and Page Break view.

upgraded Microsoft Excel yet. You should then use the compatibility
checker, which will help you find functionality or details that may not
be present with an earlier release, so you can easily fix any of these
problems before sharing them with others.

Press File, Export, and Modify File Form

Just Double-click Microsoft Excel 97 to 2003 Workbook
(*.xls) below Workbook File Types.

Select a folder place of the workbook for Saving As pop-up
box.
Enter a fresh file name (otherwise, use the one which
already exists) in the File Name box. 
Press the Save tab.
In case the Compatibility Checker appears, evaluate any
compatibility problems that have been shown.

Here is the Page Break Preview which gives you a good overview of
where the pages break during printing a text. By using this view to
you can easily press and move page breaks.

On the Display tab, press Page Break Preview in the
Workbook display group.

Normal Mode

Page Break Mode

6.22 Workbook View



Zoom Slider

Page Layout Mode
 

Zoom Using the Shortcut Keys
 

Set a Custom Zoom Magnification
 

6.23 Zoom Function for Workbooks
 

Thekeyboardvariations thathelptozoomin and zoom out of the
worksheet include the use of:

For opening the Zoom dialog window, selectthe Zoom option. The
Zoom dialog window includes default magnification settings ranging
from 25 percent to 200 percent, the custom magnification or
zooming options to match the current range.

To set up a custom zoom acceleration: The Zoom group's
Display tab includes three ways to change your spreadsheet
view easily. When zoom, 100 percent, and Zoom for
Selection.

Byusingthe Page Layout view, it helps to see from where
pages start and finish and to include headers as well as
footers.
Just click the page layout, which is on the Display tab of
any Workbook Views group.

Thereare3 waysto zoom morein on a working sheet.
The zoom slider is located on the home screen
The Zoom tool is located on the Microsoft Excel ribbon at
the view tab
The Zoom at or roll along with the Intelli-Mouse choice



ALT key.
The Key of ALT with W and J enables the 100 percent
zoom function at the ribbon.
The Key of ALT with W and G enables the Zoom at ribbon
to be picked.
The Key of ALT with V and Z unlocks the Zoom dialog
window.
The Key of ALT with W and Q unlocks the Zoom window.

In case you have a huge data table in Microsoft Excel, it might help
freeze the rows and columns. In this method, you will hold rows and
columns visible when scrolling across the rest of the workbook.
Just follow the following to freeze your top row.

Select Freeze Panes right from the Display tab of the
Window Section.

Then press the option called "Freeze Top Row."

Finally, Scroll with a mouse just down for the rest of your
worksheet.

As a result, Excel will immediately attach a dark gray colored
horizontal line to indicate that your upper row is now frozen to its
user.

To retain the worksheet section accessible when scrolling to another
section of the worksheet, then go to the Display tab, from where you
freeze panes easily to lock particular rows and columns in place can
break panels to make different windows in the same worksheet.

In case you want to freeze the left side column instead,

6.24 Freezing Pane and Splitting Windows



click view,
Column.

then Freeze Panels, and then Freeze First

To break the panes, you must follow the mentioned instruction below.
Pick a cell under the row you intend to split—choosing row 13
divides the said worksheet under row 12. Then click Display,
Window, and Break. Delete the split by pressing the Split key again.

Before you provide the simple Microsoft Excel formula list, let's
describe the main words just to ensure we're on the very same page.
Now, what are we going to call a Microsoft Excel formula and Excel
function? The formula is the expression that measures values inside a
cell and in a cell set.
For example, equal to A2 sum, A3 sum, and A4 sum are a formula
that sum values cells A2 by A4.
The function is a predefined formula that is already available in
Microsoft Excel. Functions do specific calculations in a particular
order dependent on specified values, which call arguments or
parameters. For example, instead of defining an individual amount to
be added as in the formula mentioned above, you can also use the
SUM method to add some cells: equal to =SUM (A2: A4)
Now you can easily find all the Microsoft Excel functions present in
the Function gallery on the Formulas icon:

There are more than 400 functions in Microsoft Excel, and the
amount is rising from one version to another version. Of course, it
isn't easy to memorize all of them. Also, you don't need to do this.
The Function Wizard can help you to locate the function that is
ideally fit to a given role, whereas the Microsoft Excel Formula

6.25 Show Formulas

For Splitting the Panes



Intelligence can prompt the syntax and arguments of the function as
quickly as you enter the name of the function proceeded with the
help of an equal sign inside the cell :

Click the name of the function that will transform into a blue color
hyperlink, which will open the Support topic for this function. Below
are a few simple formula examples that you should use and learn.

In MS-Excel, the AVERAGE function does just as its name looks, i.e.,
it seeks an average for the data, or arithmetic mean, for the numbers.
It has the similarity with SUM's syntax:
AVERAGE (number2, [number3, number4], …)
Getting a closer look at this formula will provide you an idea that this
formula is centered on the stated formula; what it does is, first,
determine your data values from cells B2 and B6. Then divide the

The first Microsoft excel function that you shall be associated with is
this one that executes the simple arithmetic procedure of the
addition. When required, you may make other sums with a single
formula, e.g., add values in the cells B2 via B6, and then multiply the
total by five:
Put the formula as = SUM (B2:B6)/ (five) 5)
To sum up the parameters, just use the SUM IF method, in the first
argument, join the list of cells which will be evaluated against the
requirements (A2:A6), in the second argument—the criteria
themselves (D2), and final argument—the cells to the sum of
(B2:B6):
SUM IF (A2:A6 and D2 and B2:B6)
In your Microsoft Excel worksheets, the formulas can look identical
to the following :

SUM

AVERAGE



The formula for MAX and MIN is mostly used to find the maximum
and minimum values as it offers a methodology to do so. So, we
need to use formulas that are easy to do calculations on.
Type=MAX (B2:B6)
Type=MINIMUM (B2:B6 )

If you want to find out that how many numbers a cell contains in a
given set or how many times it holds statistical values (i.e.,
number or date), you can easily measure the number of cells
containing numeric values using just a calculator or by hand,
Whereas the Excel feature for counting is very fast; it will return
the count in no time.
For each row, count the values from value1 down to value2. As for
the COUNT function, if the cell is null, it just counts. If it has a higher
value, it will count it. Even if the cell has logical values, the function
will work
The program COUNTA[value2, [value3], …]
For, e.g., if you want to find the number given in a cell residing in

outcome by the number of total numbers. The Excel feature for
AVERAGE is executing these equations quietly
in the field. As an option, if you divide the total over the count, you
may copy the formula into the cell. The typical number is (B2:B6) For
making the average of the product of all the cells depending on
their state, take the given formula where (A) is the parameters set,
(D) is pointing to criteria, and (B) is the cell that will be averaged:
type"=Average if (A2:A6,D3,B2:B6)"

MAX & MIN

COUNT & COUNTIF



column B that has a certain meaning, by: =COUNT (B: B) It will count
all of the cells which are not empty in column B, and a
basic formula is: CountA(B: B)
As shown in the formula, consider it important to use the "whole-
column-reference" (B: B) it applies to all of the cells inside column B.
The key distinction between COUNT and COUNTA is that COUNT
deals exclusively with integer values, and COUNTA outputs the
complete number for non-blank cells residing in column B ,

Based on the amount of IF function feedback on the developer’s site,
the IF feature is the most common function used in Excel. You may
use this formula to query a spreadsheet for evaluating a condition and
returning one value or executing one measurement if that condition is
satisfied, and the alternative value if it fails to match the criteria.
IF(logical test1,[value if true],[value if false]).
For example, if there is at least one completion (i.e., meaning is there
for column C) or not, the given IF statement tests. Then for evaluation,
you first make use of the "not-equal-to" operator ("<" in this case) in
conjunction with that an empty string (") ("). If cell C2 has a certain
meaning in it, the formula will return "Yes," and if not, then "No" will
result.
Here is the syntax IF(C2<>"", "Yes", "No")

Often you would only like to print a portion of the worksheet. You
should specify the area such that, if you print, only the set of cells will
be printed.

IF Function

6.26 Select the Print Area and the Microsoft Excel
Workbook



Choose the cells that you intend to print.
Select the Layout tab of the page.
Press the Print area tab.
Select Set Print Field.

A dark-gray border exists across the printing field when you go for
print, only cells inside the range shown on the page.

To begin, you need to first select or identify the workbook you want
to share. Just click the File icon to access the Workbook in
Microsoft Excel. In the left window, choose to share. The figure
under “indicates” the initial setup of the share, along with the Invite
Person option chosen.

For an excel worksheet, the Excel program dynamically splits the
document into a few parts depending on the spaces or boundaries it
approves or distributes. However, this function can be altered to split
the pages up for printing into individual sheets.

Press on the Display link.
Scroll to view the next tab (page break).
Select "Remove All" from the status bar in the lower left
hand of the slide. This excels sheet will appear in Page
Break Overview view modes.
To skip forward in the text, you can press and drag the
page to switch to a new position.

Using the Page Breaks

6.27 Save your Workbook to Remote Destinations



Just clicking Share inside the left navigation pane will open the
sharing method.
You need to save the excel workbook to a cloud destination before
you can post it. Please press Save to Cloud option. Identify the right
spot, then. Click the Live SkyDrive icon. Then press the SkyDrive
account, just like the one seen in the figure below .

After you have finished saving your workbook remotely to the
SkyDrive, now you have several choices, as shown in the Figure
given below, for managing user's access to saved files. Some
choices need further research on your own. You can search for them
on the internet too.

From this point onwards, you are now able to share file locations
with others. For sharing data in Excel 2013-2019, click the File menu
in the ribbon, then click Share, and finally select Excel's several
sharing options in detail.

When Excel is accessed, an individual may have an invitation to
modify the file, and doing so saves modifications instantly to the file
remotely. Just in case you don't wish the file to be changed by
anyone else, then options are available, and you can search for
them from the editing section and dropdown menu.

Now is the time to give out your invitation links to everyone on your
invitation list. To share this page, simply press the Share icon. If you
respond to an invitation, Excel gives you a text message.



7.1

Home Tab

 Ribbon Navigation

CHAPTER 7. Make a Basic Understanding of the
Main Screen

The MS-Excel Ribbon Home Tab includes the basic editing

MS-Excel Ribbon is the first subject discussed by our Introduction to
MS-Excel. The ribbon is a tab first released with MS Office 2007, is a
core component of the MS-Excel app, which provides links to much
of its functions, services, and amenities. However, now it's the case
for all advanced product bundles. There is also a range of other ways
to control Excel functions and circumvent the MS-Excel Ribbon .

The beginning screen is the first MS-Excel screen when you launch
the Excel program. The screenshot below displays the Launch
screen in MS-Excel 2019. The Excel Launch Screen is displayed
into two panels: 1) the left panel, 2) and the right one.

The panel (colored in green) placed on the left side includes many
recently accessed Excel data. The list below that includes recently
opened MS-Excel sheets is the "Open another workbook"
component. If you press "Open Other workbooks," MS-Excel brings
the Backstage display where a current Excel folder can be accessed.
The most significant button on the right panel is called "Blank
workbook" You will open a fresh blank MS-Excel workbook by
choosing the "Blank workbook" tab.
The latest Excel workbook includes a single original worksheet
(marked as Sheet-one) in the new workbook (marked as Book1), as
seen in the picture given below.



& formatting options that you use the most. The Clipboard
provides a long-winded way to execute
basic clipboard operations. Split, Copy, and Paste. Mostly,
people want to use keyboard shortcuts (Ctrl-X, Ctrl-C, and
Ctrl-V) or select certain options from right-click menu).
Font helps you adjust the versatile appearance of text you
join in your Excel spreadsheets, e.g., font, scale, and color.
In MS-Excel Ribbon, The Font includes the Launcher
press, which shows you the Format Cells box, and the Font
tab is enabled.
The Orientation offers flipping and wrapping text
commands—helpful for lengthy headings—to combine cells
and monitor all horizontal and vertical orientations.
In MS-Excel Ribbon, The Alignment feature includes a
launcher button that shows the Format Cells box was
activated by the Alignment tab this time.
MS-Excel Ribbon offers the Number option, which offers
data display options, such as managing how many
decimals are placed with the numbers and pattern of dates
displayed on the screen.
Number Category includes the Launcher button that shows
the Format Cells display box triggered by the Number tab.
The Styles Category offers automated formatting choices in
comparison to manual formatting provided by Font Group.
Such solutions provide strong conditional formatting
commands from MS-Excel.
The Cells category offers commands to control cells,
columns rows, like adding, removing, and defining widths
and heights. MS-Excel also provides choices for hiding,
shifting, and securing the Excel sheet overall.
Editing has a range of common commands for inserting
and manipulating cell details. The AutoSum method is used
to construct basic formulas with only single or double clicks



easily. e Sort & Filter options can easily sort the data
vertically where the cursor is placed. The category also
provides options for removing, locating, and replacing
records.

The Tables Category helps you build Excel tables (used to
record column information) or pivot tables. While the pivot

tables contain their information throughout the workbook
cells, they then forbid usual entry to that same cells; those

individuallycells throughout the pivot table can't be 
changed.
The Drawings Category provides possibilities for
incorporating electronic images and vector graphics for
Excel. Photos may be dragged from a hard-disk or the
internet—there is also the ability to search images from
Bing. Vector photos may be drawn in MS-Excel using the
figures and Smart Art keys. The Screenshot button helps
you record every aspect of any window running on your
monitor screen.
The Excel Ribbon Applications category lets you use MS
Office Solutions apps. Office applications are identical to
Apple and Android applications—they are simply the apps
that Excel (or different Office software) can host; they have
a valuable feature or utility that is not indigenous to the
program.
MS-Excel Ribbon Charts Category helps you to connect
Excel diagrams and pivot diagrams to your workbook. The
pivot map is essentially a chart that utilizes a pivot table as
a database rather than the standard Excel data limit.
MS-Excel Ribbon Charts Category includes a launcher icon
that shows the same dialog box as when you press the
suggested Charts button.

Insert Tab



MS-Excel Ribbon Reports Category comprises just a single
item—The Power display icon. Power View is the default
Excel add-in that needs to be enabled. This helps you to
create beautiful market visualizations powered by the latest
Excel Data Model.
MS-Excel Ribbon and Sparklines category help you to add
sparklines in your workbook. Sparklines are miniature
maps that are seen in cells, typically next to data they add
and offer valuable visual cues as to patterns.
The MS-Excel Ribbon Filters category includes buttons to
connect slicers and timelines to columns, pivot tables, and
maps. These two components have a highly interactive
framework for filtering arranged data. Slicers may be used
for any form of data kind, while timelines are used in
filtering dates.
The Excel Ribbon Ties category includes the Hyperlink
click only. Hyperlinks function in almost the same among all
MS Office goods. In MS-Excel, you can put a hyperlink click
to any cell or set of cells, which will carry the user to some
other workbook, open a separate workbook, generate a
new email address, or open a website.
The text helps you attach text-based items that exist on the
entity's layer above the worksheet cells. You might include
text frames, head footers, WordArt, signatures, and use the
MS Object Linking Embedding technologies to attach
objects.
The Excel Symbols category has choices to insert
calculations and symbols. Symbols may be introduced in a
cell as every other character. However, calculations are
embedded in the text box on the piece's substrate at the
top of the worksheet cells. Excel offers a complex
calculation toolbar to customize calculations, featuring
thousands of arithmetic and science symbols and forms.

Page-Layout Tab



The Themes Group enables you to use the default Themes
feature that is now popular with all MS Office products.
Themes give a simple and fast way to control the layout of
the entire article. Selecting options from the features,
Colors, icons, and Effects drops menu items found in the
features Group can change the look of the cell types and
graphic materials in a single hit using stylish and well-
coordinated colors.
Excel Ribbon Page Configuration Category includes
commands that you usually want to use when printing a
file, for example, to adjust borders, alignment, and page
size and define the area of the print.
Excel Ribbon and Page Setup category include a launcher
button that shows the Page establish dialogue box and
Page Setting tab allowed.
The Scale to Suit Category includes the commands
contained in the Scaling portion of the Page Configuration
dialogue.
Excel Ribbon and Size to Match Category include a
launcher button that shows the Page Configuration
dialogue box triggered by the Page tab option.
Excel Ribbon and The Sheet Options Category include the
option for hiding and viewing gridlines, column, and row
headings on both computers and at the time of print.
Excel Ribbon and The Sheet Options Category include a
launcher button that shows the Page Configuration
dialogue box, this time triggered by the Sheet tab options.
The Excel Ribbon and The Organize Category include a
variety of separate Tab options. It provides a set of
commands that align and organize items, such as Carry
towards Front, Sends towards Back, and separate.

Formulas Tab



The Feature of formula Category helps you to connect all of
Excel's few hundred tasks for formulas. The functions are
split into divisions, with the final stage (More Functions)
revealing, in a submenus sequence, all categories with no
decline-down menu.
This category does not require a launcher icon, as the key
formula-related dialogue (Insert Structure) can be reached
through the final choice in all of the drop-down options. The
Excel Ribbon Identified Names category is associated
with the development and administration of names. In
comparison, Names are just an Excel resource that helps
you to connect a text mark (name) with a set of cells, an
equation, or a static attribute (taxation rates). When
building a formula, you should be using the name rather
than the value it reflects. This brings consistency to your
equations and allows you an effective mechanism to adjust
several formulas by modifying the meaning consisting of a
single word.
Excel Ribbon and the Formula Auditing category options
are built to help you identify flaws within formulas. Using
such choices, you can easily spotlight the cells with which
the formula applies, and likewise, or step through with a
complicated formula, sentence by sentence. The Excel
Ribbon Computation category has commands
that monitor how and then when Excel executes
calculations. There is a need to measure the formula's
results that may negatively affect the functionality of a
worksheet in worksheets containing several equations
formulas that connect to outside workbooks. This category
then provides the option to render a manual calculation so
that Excel can only execute calculations when you press
the Calculate Now icon.

Data Tab



The Get outside Data tab includes commands used to insert
data from various sources into Data Structure and could
then be used to execute data processing and visualization,
utilizing pivot formulas, pivot charts, and the Power View
option. All these functions can also be contained in the
Power Pivot option, which gives you a variety of potential
functionality for modeling acquired sets of information.
The Excel Ribbon Links tab has ways to deal with current
ties. The Relations button shows the Worksheets
Connections dialogue where you can search and uninstall
connections. The Refresh Everything button helps you
swap old versions of downloaded files, indefinitely
preserved in a data structure, with the new edition from its
actual author. The MS-Excel Ribbon Sorts & Filter tab
commands enable
you to conduct simple & advanced sorting and tabular data
processing. The Sorts A to Z & Sorts Z to A keys enable
one-click sorting through a single column, whereas the Sort
button shows the Sort menu to enable multi-column sorting,
color sorting, and personalized sorting.
In the same manner, the AutoFilter button helps you to
easily filter details according to predetermined parameters,
while the Specialized Filters command enables you to
separate data that meets more complicated criteria.
The MS-Excel Ribbon Computer Tools tab offers access to
advanced, integrated MS-Excel utilities, one of which
executes a useful information manipulation job. For
example, the command Texts to Columns helps you filter
information currently inside a single column (usually after
being compiled into MS-Excel) into different columns. The
category also provides strong Delete Duplicate files and
Flash Fill instructions.
The MS-Excel Ribbon Research Methods (Goal Search,
Scenarios, and Datasets) also include data analysis tools



that have become part of MS-Excel's age-old arsenal. The
MS-Excel Ribbon Layout Category is home to some
other long-standing MS-Excel function named grouping and
highlighting—applying a level of self to various rows and
columns. This skill is really helpful to make it easy to
handle and control huge worksheets.

The Proofing tab includes the popular Spell-checker and
Text commands; and a testing method that helps you
conduct searches in a variety of local and web resources,
like Bing and Encarta.
The MS-Excel Ribbon Language tab is a subclass of an
analysis method that helps you convert familiar terms and
phrases from it into more than thirty different languages. The
MS-Excel Ribbon Comments tab allows you the option
to annotate feedback on workbooks, also for your gain and
as a workspace facility, and express your views on
workbook material with colleagues. The category has
buttons for making, uploading, removing, posting, and
hiding messages.
The MS-Excel Ribbon Adjustments tab has the strongest
commands on the Analysis Page.

The Protective Sheet and Protective Worksheet commands
can also be used to limit access to particular cell ranges,
monitor user changes, and maintain the worksheet layout.
There are several commands to exchange worksheets with
other users and log improvements made to the same
worksheet by various users.

Review Tab

The View Tab



A new Support tab appeared in MS-Excel throughout 2018. The MS-
Excel 2003 Support menu was limited to a circled query mark in the
upper right corner of MS-Excel 2007-MS-Excel 2016. Support is a
complete ribbon tab now.

The very first icon is MS-Excel Support online. Excel users
have regretted the transition to online support and have

Workbook Views tab buttons adjust the ways the workbooks
are displayed. The regular view is designed for speed; Page
Split Preview enables you to configure the page; Page
Design offers an accurate overview of how papers are
printed. This view enables you to save more on- screen and
site configuration attributes.
The MS-Excel Ribbon Display tab has commands that help
you view and hide the MS-Excel GUI's main elements, like
row or column headers, grid lines, and formulation bars. The
MS-Excel Ribbon Expand tab buttons monitor the
magnification you see in your job. For example, you may
illuminate a list of cells and press the Maximize to select
key to automatically maximize in or out MS- Excel so that
the chosen range could fill your screen. The MS-Excel
Ribbon Windows Category provides
solutions that help deal with a variety of several
documents. For example, the Organize All commands
would simplify and scale all windows presently opened so
that you could see its contents simultaneously. The MS-
Excel Ribbon Modifiers tab also has common
drop-down control that helps you display most of the
modifiers in all the other open worksheets and create
original macros. (Macros are just an automated set of
instructions that can be performed automatically by clicking
a key.

Help Tab



always been fond of recalling the olden days of offline
assistance. Although, with time, online support is improving.
There have been about 2,000 web support posts and more
than 50 million views each month.
Feedback lets you submit a screenshot and a comment on
what you want or don't like. The Excel team is constantly
reading these suggestions. The display guide unlocks a
support panel with a range of
recent videos incorporated into Excel.



Expanding the Formula Bar or Tab

CHAPTER 8. Formula Bar

8.1 Navigating on a Ribbon to Use the Formula
Tab in Microsoft Excel

 

Formula Panel is where all the details or formulas are inserted in the
workbook for the selected cell is displayed. You may use the Formula
Tab to change the information or formula with an active cell.

The current cell reveals the effect of its formula when we read the
formula through the Formula panel.

Formula Bar seems to be the region at the peak oftheExcel display,
just under the ribbon area and the Formatting bar, based on your
Excel edition The Formula Panel has two components: Name Box
placed left, and the component of a currently active cell are placed at
right extreme.
If you'd like more space to access the spreadsheet, or if you're not
using the detail given either by Formula panel, you may turn it off.
For checking the show of a Formula panel, follow the steps below:

Show the MS-Excel Options dialogue window. MS-Excel
2010 or older, view the ribbon File button and then press
Options. Excel shows the MS-Excel Option dialogue box.
Select Advanced on the left-hand side of the dialogue box.
Scroll down before you see the choices for View

Select the Show Formula panel check box. If picked, the
Formula Bar will be shown; not selected indicates that it will
not be shown.
Select OK.



The Formula panel can be spread in both horizontal and vertical
directions based on your requirements.

To stretch the Formula panel horizontally, transfer the
mouse pointer to the region between the Username Field
and the Formula panel before the cursor transforms it into a
horizontal multi arrow. Left-click then drag to change the
horizontal scale.
To stretch the Formula panel vertically, transfer the mouse
pointer to a Formula panel region base before the cursor
transforms into a vertical multi-pointer. Left-click then drag
to change the horizontal scale.
There is an extension or deal toggle on either right side of
its Formula Bar. Use this to change the Formula Bar easily.

You may also cover the Formula Bar fully by heading to a View panel
and unmark the Formula panel option

Pick the cell wherever you want your data is to be entered
and start typing.
When you enter the data in any cell, the data will also show
in the Formula panel.
To acknowledge the results, either tap the Check Mark
button or hit enter. To remove the info, either select X or
push Esc.

The procedure for joining a formula is just the same, except that all
formulas must start with "=" (no quotation marks). To change any
information and formula in every other cell, pick a cell and then click
Formula panel or push F2 for accessing the Edit Mode option.

Entering or Modifying Your Data Into the Formula
Bar Section



9.1  Understanding the MS Word Interface

CHAPTER 9. Creating a Spreadsheet in MS Word

MS- Word allows the customer the flexibility to seamlessly combine
excel data within only a word document. The Insert tab helps you to
incorporate excel data quickly. MS-Word is indeed a word
processing program that helps you produce a range of pages and
other types of data, such as emails, flyers, and studies. With the
launch of many upgrade features—including the opportunity to build
and work on online documents—Word 2019 offers you the power to
achieve something with any word processing venture.
The Word Starting Screen will show whenever you open Word 2013-
2019 for the very first time. From that now, you can build a new
document, select a template, or view the existing one .

If you had used Word 2010 and 2007 before, Word 2013, 2016, and
even 2019 might sound familiar. It tends to utilize elements including
the Ribbon and Fast Access menu bar; you can find commands to
execute basic Word tasks—as the Backstage display.
The term in 2013 utilizes a tabbed ribbon framework instead of a
conventional menu. The Ribbon includes several tabs, including one
with a set of command classes. You could use these menus to
execute the most frequent Word functions.

While MS-Excel is the MS-Office program and better recognized as
a spreadsheet program with many features, there will be occasions
where you need a spreadsheet inside a company report or several
other Txt files. You may build an MS-Excel spreadsheet in every
other Word document by inserting it as an entity in the text. Word
simplifies the operation by giving you various ways to create a
spreadsheet. You may access the choice from Insert Table menus
or Insert Item menu.



Choose Insert tab.
In the Text Category, press the Item command.

There would be a dialog box. Pick Build from File tab, and
then press Search.

Locate and pick the Excel file you like, then press Insert.

Check the box beside the document's path if you want to
link the information to the MS-Excel table. This will cause
the Word map to update itself as adjustments are made to
the MS-Excel chart.
Select the OK tab.

And for the time being, we're just hitting the insert tab, so only this
tab can be required to function with excel.

Click or press the Insert tab.
Start moving the pointer where you'd like the table to be
embedded in your text.
Tap the icon of the table.
There is a pull-down option.
Then choose the Excel spreadsheet. And observe the
direction given below.

9.2 MS Word Importing Spreadsheet
To Embed Excel in the Word



The map would show in your Wordbook. Double-click the
map to edit the built-in chart. An MS-Excel
spreadsheet including the source data of the map will
emerge. When you've done editing, please ensure to save
the MS-Excel map.



10.2 The Pie Charts
 

10.1 The Charts and Their Types
 

CHAPTER 10. Creating Charts in Excel and Their
Types

For large enterprises and small businesses or personal data, we
utilize MS-Excel to store information. Although spreadsheets are
essential for data processing, they are also bulky and do not provide
team participants with a convenient view of data patterns and
relationships. MS-Excel will help turn their spreadsheet data into
graphs to construct an intuitive analysis report for certain data and
make accurate business decisions.
MS-Excel 2019 lets you build a graph or chart that suits practically
every function. If you have developed the MS-Excel graph or a chart,
you could also use the Template tab to customize and adjust the
graph for your needs. Find out how to construct an Excel 2019 chart.

Agraphical view in bars andothershapes is also referred to as an
MS-Excel graph. It's a graphic depiction of information from a
workbook that will add greater understanding to information than
simply looking at the figures. A chart is a versatile tool that helps you
to visually view data in a range of formats, like Bar, Column, Pie,
Graph, Zone type, Doughnut shape, Scatter dots, Floor, or Radar
graphs. It's a quick and good approach to build a chart using Excel.

Piecharts are normally used to display the contributions or individual
worth of various values, incorporating the overall value. The Pie
chart often uses a single set of data.
For building a pie chart from the 2017 or 2019 edition of excel on a
data set, just perform the given set of instructions.

Choose your data set from the range of A1:D2.



Right-click the bar graph and click the Data Label Type
icon.

Select the Pie symbol/sign on the Design tab given in the
Chart’s category.

Click on Pie.

As a result, you will see something given below.

To pick the entire pie, tap on the pie. Tap on a piece of the
chart to pull it away from the middle.

Results:

Remember, if you've got a numeric label, blank the cell A1 before
making a pie chart. By doing so, MS-Excel would not consider the
figures in the column. Also, as a dataset, and automatically construct
the right table. After making a chart, if you wish, you could insert the
content Year in step 1.
Choose the category A1:D1, keep down CTRL and pick the category
A3:D3.

Click on the icon only at the lower bottom (follow the
previous move of inserting the graph) and click Delete.
Choose a pie chart.
Click the + icon on the appropriate side of the chart and
select the Data labels check box.

Tap on the paintbrush button on the chart's appropriate side
and adjust the pie chart's color theme.



Test Name of Type, uncheck Value, test Percentage, and
press Middle.

So, you're going to get everything like this.

You would need to do the following measures to build a column chart
in Excel:

Highlight the details you intend to use for the column chart.
In this case, we choose range A1:C7.

Choose the Insert tab in the toolbar at the top of the page.
Press on the MS-Excel Column chart button in Charts
Category, and then pick a chart from the drop-down display.
In this case, we choose the first column chart (known as
Clustered Column) in the 2-D Column segment.

You'll see the column chart shown in your rectangle bar
spreadsheet to reflect all revenue and cost figures. Sales
prices are shown in vertical blue lines, and costs are shown
as vertical orange lines. You could see the values of axes
on the left side of the graph for such vertical lines.

Finally, let's change the column chart description.
To change the title, press on "Chart Title" button at the top
of the graphic item. You must be able to see the title being
editable. Insert the text you'd like to see as a title.
Throughout this tutorial, we insert "Sales and Expenses"
like column chart word.

10.3 Column Graphs

10.4 The Line Charts



You would need to do the following measures to build a bar graph in
MS-Excel
2016-2019.

Highlight the details given in the cell you intend to use for
making a bar chart. In this case, we choose a range from
A1:C5.

Choose the Insert tab in the toolbar at the top of the page.
Tap the MS- Excel Bar Chart key in Charts Group and then
pick a chart from the drop-down display. In this case, we
choose the first bar chart (known as Clustered Bar) in the
2-D Column segment.

A chart with long bars, usually known as a bar chart, is a type of
chart used to visualize data's meaning over a certain time. E.g.,
the accounting department might plot a shift in the amount of
cash that the business has on its hands over time.

First of all, one should make sure that the information is
formatted correctly for creating a bar chart.

Use Smart-Draw Add column, press Graph, and select line
Graph.

Choose the data file you want to upload for creating the
chart, and Smart-Draw would automatically create your
chart.

Once imported, you could easily adjust the description,
legend placement and also instantly change the form of a
graph using Edit Graph tools or double-click imported
graph.

10.5 Bar Charts



Pick the set of worksheets A1:B11.
Click XY (Scatter) chart order button on the Insert page.
Pick a subtype of a graph that does not have a graph.
Excel can show the data in the XY (Scatter) table.

Excel charts and graphs follow the same processes. Let’s take an
example to understand how to create the Area chart.

We have smart quarterly revenue data for the area.

Choose the details.
Go to Design tab > charts group > press Field graph.

From the region graph, press the Clustered Area Graph.

Now you can see the bar chart shown in the horizontal bar
spreadsheet to reflect both the retail life and shelf life of
each commodity. The shelf life is shown as orange
horizontal lines, and the retail life is shown as blue
horizontal lines. You could see the values of the axes at
the bottom of the graph with these horizontal lines.

Finally, let's change the bar graph title.
To adjust the title, press on "Chart Title" button at the top of
the graphic item. You must be able to see the title being
editable. Insert the
text you'd like to see this as a title. Throughout this tutorial,
we enter "Product Life" as the bar graph word.

10.7 Scatter Charts

10.6 The Area Charts



Verify the data organization of the chart results.
Confirm that MS-Excel has structured the data
appropriately by watching at the table.
If you're not pleased with the graph's data organization—
maybe the data looks backward or flip-flop—click the Turn
Row/Column command key on the Chart Tools Interface
page. (You may also play with the Turn Row/Column
function, so do it if you thought it could help.) Notice that
data is ordered appropriately. The graph demonstrates the
common-sense finding that increased advertisement
appears to be related to increased revenues.
If required, annotate the chart. Attach those tiny blossoms
to your chart, which would make it much more appealing
and readable. For instance, you could use Chart Title and
Axes Titles keys to compile a chart with such a title and a
summary of the chart's axes. Attach a trend line by
pressing the Add Chart Feature menu on the Trendline
command key. To see Add Chart Element menu, select the
Interface button and then click Add Chart Element key. You
must first choose an embedded map item or display a
graph sheet for the Template tab to be viewed.
MS-Excel will display the Trend line menu. Determine the
number of trendline or correlation calculations you need by
tapping on one of the available trendline options. For
instance, press the Linear key on the keyboard to conduct
a linear regression model. In MS-Excel 2007, you insert a
trend line by tapping the Trendline Graph Tools Layout Tab.
Insert regression equation to scattering plot.
To show the trendline equation used by scatter plot, select
More Trendline Possibilities from the Trend line menu.
Choose both Display Equation on Chart and Display R-
Squared Value in Graph checklists. This tells MS-Excel to
add regression analysis data need for the trend line to their
graph. Note that you'll need to scroll down the panel to see
these checklists. In MS-Excel 2007 and MS-Excel 2010,



As the name suggests, stock type charts can display changes in stock
prices. Even so, the Stocks Chart could be used to display variations
in other statistics, such as normal rainfall or yearly temperatures .
To construct a Stock graph, put data into columns or rows into a
particular order on a worksheet. For example, to construct a basic

A Bubble graph is like a Scatter graph with an extra third column to
clarify the bubble's size to represent data points in the data series.
The Bubble Chart has the following subtypes:

Bubbles
A 3-D visual effect bubble

tap the Trendline Chart Layout tab select More Trendlines
to display the Trendline Format context menu.
Use the ctrl key and text boxes in the Trendline Format
panel to manage how trendline multiple regressions are
calculated. For instance, you could use Set Intercept =
checkbox and textboxes to compel the trend line to
intercept the x-axis at a certain point, like zero. You could
also use Forecast Forward and Primitive texts to clarify that
even a trend line must be extended backward or forwards
beyond or even before existing data

Tap the OK button.
You could also barely see regression Information, so this
has all been annotated to make it much easier to
understand.

Stock Chart

10.8 Other Charts Types
Bubble Chart



high-low Stocks Chart, organize Information with High-Low-Close
insert as Column Names within this order. The Stocks Chart has the
following subtypes:

High-low-proximity
Open-Higher-Lower-closer
High-low-close amount
Volume-Open-High-Close

The Radar chart evaluates the combined values of a variety of data
series. Arrange details into columns or rows on a worksheet to
construct a radar chart.
The Radar chart includes the following subtypes:

Simple Radar
Radar and Markers

A Surface graph is helpful when you try to identify the right variations
of two variables. As in a topographic chart, colors and shapes denote
regions under the same set of principles. Building a Surface chart
follows these steps:

Ensure that all divisions and data series represent integer
quantities.
Organize data into columns or rows on a worksheet.

The surface chart includes the following subtypes:
3-D surface area
3-D wireframe layer
Contours
The contour of the wireframe

Radar Chart

Surface Chart



Radar Loaded

These Combo graphs combine two or even more graph styles to
make data simpler to interpret, particularly when data is varied. It is
seen with a secondary axis, which is simpler to read. Arrange details
into columns and rows into a worksheet to construct a Combo table.
The Combo chart has the following subtypes:

Panel Cluster–Line
Grouped Panel–Secondary Axis Rows
Layered Field–Cluster Line
Custom variations

In MS-Excel 2016-2019, the Chart Elements key (with plus sign
symbol) displays on the right side of the built-in panel when selected,
includes a number of the main chart items that you could apply to their
chart. To add an item to the table, press the Chart Elements key to
show an alphabet of all Axis by Trendline.
E.g., to reposition the title of the chart, press the Follow-up button
connected to graph Title on Chart Elements toolbar to view and
choose from the following choices on the Follow-up menu:

Above the graph to incorporate or reposition the chart title
to be centered above the plot area.
Focused Overlay Title to incorporate or reposition the chart
title so that it is centered at the top of the plot field.
Find more Choices to open the Format Chart Title Task
Pane on the MS-Excel Windows right side. Here, you could
use options that appear while choosing the Fill & Rows,
Effects, and Scale and Assets keys below Title Options and
Script Fill & Layout, Text Effects, and Dialog box keys
below Text Options in the task pane to change almost

Combo Chart

10.9 Customizing Excel Charts



MS-Excel automates the task of creating charts from established data
sets. If the spreadsheet already includes modified data, the chart
feature may convert this data to the graphic with a minimum user
feedback amount. The Suggested Charts tool in MS-Excel is a

every part of title formatting.

The following figure demonstrates how the study clustered column
chart appears with a data table attached to it. This information table
contains the keys to the legend as the first column.

MS-Excel provides many automatic features to deal with all these
data storage values, like a graph feature. Once data is processed
in the MS-Excel database, anybody with access to a spreadsheet
may modify data to interpret and express its significance. Chart
feature may be a central factor of these systems.

MS-Excel charts enable spreadsheet managers to build data set
visual representations. By highlighting data collection inside the MS-
Excel spreadsheet and applying it to graphing function, users may
construct different charts on which data is graphically represented. It
will help clarify and communicate the data collection with Excel charts
appropriate for management or business presentations. A chart may
give a better view of a collection of data variables than the table of
lines of figures in it, enabling administrators to integrate this
interpretation into research and plans.

10.10

Automation

Visualization

 The Importance of the Charts



vital part of the process. Using the chart feature, spreadsheet
administrators may create a chart with a few clicks, select a chart
form, and choose names and axes.

MS-Excel graph feature allows users to strike a balance between
automation and customization. Its software can create a chart
rapidly and conveniently. The user can still maintain control over
several chart specifics if appropriate. As well as customizing data
displayed in a table, users can fine-tune the chart choices to
every detail. Charts in MS-Excel can also be changed after
they've been initially created by clicking chart and choosing from
options available to change the chart sort, data, or other
information .
Integration

Customization



11.1 Adding or Changing the Headers or Footers
via Page Layout Setting

 

Making Header and Footer via Page Setup Dialog

11.2 Adding or Changing Header or Footer via the
Page Setup Dialog

 

CHAPTER 11. Headers and Footer in a Worksheet

OntheDisplay tab, press the setting for“pagelayout”inthe
Workbook Views group, and then move accordingly.

1. Select the Add Header tab.
2. In the group Heading & Footer section, tap the Latest Date

key to pick the existing date in the Insert column.
3. You may also apply details on the left and right sides of the

header. E.g., tap the left portion to add the company name.
4. Tap from elsewhere on the document while viewing the
heading. In the layout tab, in the Options group, you can
install a different heading for the first tab and a separate
heading for odd and sometimes even sections.
5. In the Display tab, in the Workbook Views group, press

Usual to go back to Ordinary View.

Adjust Header & Footer using the Page setup tab. Headers& Footer
may be picked from Ribbon, then page Layout section, press
Launcher tap Enter context menu from the group. Tap the Headers &
footer section in the Page setting text box. A user can choose
Headers & Footer or set a custom one as per their choice .



Steps
 Goback to the Ribbon

Choose the Style tab.
Tap the User Page Configuration context menu in the Page
Setup section.
Tap the Headers Footer icon in from Layout section.
Custom headers icon.
Choose your header.
Press Custom footer, yes.
Choose footer.



12.1 Selecting Table Style
 

12.2 Creating or Deleting Custom-Made Table
Style

 

CHAPTER 12. Formatting the Excel Tables

MS-Excelhelps youto build yourtable types usingthefollowing
general steps:

Go to the ribbon by selecting the Home tab.
In Styles Group, tap the Format-as-Table section. MS-
Excel shows many formats that you could use.

Rapidlyformat many cellsby selecting a table style type. You may
also make a premade design of your own. It will help you quickly
formatting a cell by selecting a cell type.
For doing so, follow these steps:

Click and make a selection for all the cells within the data
within your selection.
On the Home page, press “Format-as-table” in the Styles
group.

From there, you can choose any table style of your choice.

Remember, press New Table Type to create your first table design or
right-click table design. Now click Repeat to create a new design that
is identical to the original one. Modifying the custom table design
affects all tables in the worksheet that uses the table's said style.
This will save a huge amount of time.

MS-Excel can automatically pick the data for you. Just
check for “Format-as-Table” and press OK.



The greatest advantage of formatting data as a table is having variety
in its types and the filter choices it provides. You may find them by
clicking on a symbol with “down-face-triangles” in header lines.

Scroll down to the desired choices till the very bottom.
Choose the Latest Table Type. Excel can show the Latest
Table Type dialog box.

At this point, insert a title to be given to your personalized
table style.
Use controls in the dialog to decide how you want the
theme to appear.
To close the dialog box, press OK.

When a customized style is produced, it's also automatically added
to the Table Styles gallery:

To alter any table design, go to the Table designs gallery,
right-click on style, and click “modify”...
To uninstall a custom table design, right-click on it, and
choose Delete.

The design section of the MS-Excel table cannot be changed or
omitted.
Remember that customized table design is only usable in the
workbook where it is made. If you wish to include it in another
worksheet, the easiest approach is to copy custom type table to that
worksheet. Later, you could uninstall copied table, and the custom
style will stay in the Table designs gallery.
12.3 Choosing a Table Style for Formatting the

Elements of a Table

There are Three Methods You Can Adopt to Sort



a Table
 

 

Filter Options
 Asthename indicates, the filter choices can hide the rows

depending upon the parameters you select. At this step, no data is
destroyed. It's just briefly concealed to help you hone the data
you're attempting to interpret. You may also release filters at a
certain time by selecting Transparent Filter from [Heading] drop-
down toolbar on your PC and Clear Filter key on your Mac.

Fromsmall towards the largest or vice versa, this is a self-
explanatory method, truly. Press on the down-face triangle in the
column that you want to filter or sort in a table, and select the option at
the top of the drop-down display.
If you are using any background color for filling or color scheme is
being used manually or even using conditional statements, you could
use color to sort your results. In the given below example, we have
used the formatting option to format the top 10% of quest volumes
with yellow fill and the bottom 10% with red font .

Hence you may now sort columns by cells with yellow fill, a red text,
no fill, or a combination of two using the Sort option. If we needed
any keywords with the largest google trends to float on the top of the
table, we wouldclickon the yellow bar below the Cell Color Type.



13.1 Adding Signatures Line and Putting the
Signatures

 

CHAPTER 13. Putting a Signature in an Excel File

Whenever an Excel document has the signature attached with it, no
edits are permitted into the file without invalidating these signatures.
This enables you and many other advanced users to know that the
document has mostly been viewed and approved and stands by the
author.

Open up the workbook you would like to include adigital
signature in, but first, remember that any of your data will
not be changed or modified anymore. Place your cursor in
that blank cell near that point you would like to add your
digital signature.
Tap Insert > Signature Line > MS Office Signature Line
over your ribbon section. See the given screenshot.

In MS-Excel 2007-2019, an alarming context menu would pop up
after tapping MS Office Signature text. Just go through the option of
do not show that message again, and tap the OK to move ahead.
Now a Signature Setup context pops up; from now on, follow these
steps:

Write your name into the specified text box for signature.
Type your title inside that designated signer’s name text
box.
Write your email address inside the appropriate signer’s e-
mail address text box.
Tap the Allow button to add a comment inside your Signed
dialog box if you like to add comments into your signature
text.
Tap OK for closing your Signature Setup context menu.



Then you will see MS-Excel adds that signature text using
a graphic object into the vicinity of a cell. You place that
pointer earlier at step 2 within a bigger X symbol that
includes your name and text. See the screenshot:

Double-click your signature line with the graphical object,
and it will open the "Get your Digital ID dialog box, now you
can pick the type of ID you need. Here we check to build
your digital ID. Please see the screenshot given below:

Note: You cannot construct your first digital ID into MS-
Excel 2013-2019. The only option for you in doing this is to
press the Yes key in to Get another Digital ID tab and either
purchase or install the Digital ID. Else, click the No key to
leave. And to see the screen capture below:

Tap OK, and afterward type your details into another
textbox to build a Web ID dialog and press Create. Please
see the screenshot: Throughout the Signing menu, press
Choose Picture to
choose, then edit that first signature image. See the
screenshots:

Double-click that signature text graphic object, then open to Get the
Digital ID menu; you could pick the sort of ID you like. Here I check
to Build your new digital ID. Please see the screenshot:



Inserting Symbol

CHAPTER 14. Inserting Symbols

14.1 Adding Currency Special and International
Symbols in MS Excel

 Perhaps one ofthe most common issues, orwe say everlasting
problems is about introducing characters or special characters into
Office text. Especially the Symbols and characters that are not on a
keyboard. The most frequent requests are included currency
symbols such as Pound £ Eurozone or Yen/Renminbi Δ, and could
even include @ sign that may always be absent from an old
keyboard.

You may add characters to Word through Insert | Symbol, which
would be a perfect option with occasional usage. It's on the Insert tab
positioned on the far-right side of the Title, MS-Excel, and PowerPoint
tabs.
Recently utilized symbols are shown in a gallery, so you could press
on the symbol you want to add easily.

Or, to open up the complete list of Symbol dialog, select
Further Symbols.

When there is no sign of your desired choice, there are ways to do
so.
Look for the icon you like. We check for symbol name “plus” with the
term 'Unicode' (e.g., 'Signature Unicode') that identifies sites that
have Unicode sign value.
Unicode is a widely recognized IT norm for letters and signs. Each
character is allocated a number that is decided upon by all computer
systems. More than 143,000 characters are listed in the current



We think two brackets are a little clumsy type, but you should still try
quicker alternatives. For example, tilde ~ character is not often used
and may be prefix or suffix for the sequence of two Autofill character
entries. For instance,

~e or e~ is the sign of the euro
~s or s~ is UK Sterling sign
~c or c~ is the copyright mark
~r or r~ is the authorized trademark sign
~t or t~ is a trademark sign
~y or y~ is the Yen sign

UNICODE and UNICHAR features have been usable since MS-
Excel 2013 and are close to previous CODE and CHAR features.
The Munich function is probably the most useful since it returns a

The Specific Character page has a small list of certain symbols that
have a shortcut key.

Unicode catalog, including all existing languages and a few historical
events. What you're searching for is the hex Unicode number mark.
They have the option to see in the U+ prefix. For, e.g., the trademark
sign is “U+2122,” as seen in the right-hand column.

Enter Unicode hex meaning in Unicode Character Code
menu (hex).

Tilde Shortcut

Special Characters

14.2 Inserting Symbols Using Your Keyboard
Shortcuts or Asci and Unicode



symbol for a specified numerical point (UTF-8 and UTF-16).

=UNICHAR (10004) will result in ✔
=UNICODE("✔ ") will result in 10004
“Alt0164” can be used for ¤ a Currency symbol.
“Alt156” can be used for making a £ Pound sign
“Alt 0128” can be used for making € Euro sign
“Alt36  “can be used for making $ Dollar Sign
“Alt155” can be used for making ¢ Cent Sign
“Alt157” can be used for making ¥Yen sign
“Alt158” can be used for making ₧ Peseta sign
“Alt159” can be used for making ƒ Frank / Gulder sign

To add the ASCII character, click and hold ALT when accessing the
character code. For instance, insert the degree (o) icon, press, and
hold ALT when typing 0176 on a numeric keypad .
It would help if you used only the numeric keypad to enter the digits,
not the keyboard at the top of alphabetic numbers. Be sure that NUM
LOCK keys are on if the keyboard has to enter the numbers on the
numeric keypad.
You should adjust the currency for any particular cell. If you're doing
something more, make sure cell numbers are configured as
currencies. To do this, pick the cells that you'd like to format.



15.1 Move Text Box Word-Art and Shapes
Forward or Backward in a Stack

 

CHAPTER 15. Bring the Elements Forward and
Backward in MS Excel

When addingimages, shapes, or otheritems to Office documents,
they immediately stack into separate layers when adding them to
Office documents. You may transfer individual images or other items
or categories of objects into a stack. E.g., you can transfer items
forwards or backward within such stack one layer at a time, or you
could move them to the top or bottom of the stack through one move.
While users draw, you will combine items to produce various results.
You should follow these measures to transfer forms, photographs,
texts, and word art in a stack.

Select the WordArt, form, or text boxes you'd like to

Whenever you build some MS-Excel objects using the Shapes tool
on the Insert through ribbon page, each form is drawn on its very
own layer. This implies that all items are autonomous and may be
shifted to the top of many other objects. There might be moments,
though, where you need an object being under another item. You
will do this taking the following steps:

Tap on the shape you intend to alter in terms of changing
the design. There are little square boxes known as handles
along the circumference of the object.
Go to the ribbon format tab.
In Organize group, press Send Backward or use MS-Excel
2007 and newer models, press Send Back.
You may make arrangements by selecting Carry Forward
rather than Send Backward or Carry to Front rather than
Send to Back. MS-Excel pushes an object that might be
behind others such that it overlays others.



We're going to organize the T-shirt ordering alphabetically
with the Last Name.
Choose a cell in the column that you'd like to filter through.
In our case, we're going to select cell C2.

Choose the Data tab on Ribbon, then press the A-Z button
to sorts A to Z or Z-A key to sort Z to A. In our case, we're
going to sort A to Z

The workbook will be ordered by chosen column. In our
case, the workbook is now ordered by the last title.

transfer up or down the stack. Press either Carry Forward
rather than Submit Backwards on the Drawing Resources
Layout page.

You may opt and transfer the item up to another layer or
top of the stack. Send Backward has identical options:
below one sheet (Send Backward) or down the stack's
bottom (Send to Back).

In MS-Office 2013 and new releases, whether you have
many WordArt, forms, text boxes, or even other objects, it
could be better to use an upwards arrow in Selection Panel
to transfer The Selection Panel is not eligible in Project or
MS-Office 2010.

15.2 Grouping & Sorting
Sorting



Custom Sorting
 Inour case, asmention below, we want to sort the T-Shirt Size

Workbook. A standard sort would order sizes in alphabetic order,
which would have been inaccurate. Instead, we can build a custom list
to order from the smallest to the biggest.
Choose a cell in the column that you want to filter through. In our
case, we're going to select cell D2.

Pick the Data tab, and then press the Sort button.
The Type dialog box would be shown. Choose a column
that you'd like to sort, then choose Custom Set from an
area of Order. In our case, we're going to want to sorts the
T-Shirt Size.

The Design Items dialog would show. Pick the Latest Set
from the Custom Lists box:
Type products in the desired custom order package in a list
of entries. In our example, we're going to sort our T-shirt
size data from smallest to largest, so we're going to type
Tiny, Medium, Big, and X-Large clicking Enter on a
keyboard for each object.

Select Add to latest request. The latest list will be applied to
the Custom list box. Make sure that a new list is chosen,
then press Yes.
The Customized Lists text box will be locked. To execute a
custom type, press OK in a Sort dialog box.
The workbook will be sorted through custom orders. In our
case, a workbook is now arranged in t-shirt sizes from
smallest to biggest.



Grouping
 

Multilevel Sorting
 

TheSubtotal function demands that your values are grouped. We're
sorting by business titles, so the first stage is sorting by that column.
Press within the Business column and select Sorts A to Z from the
Sorts & Filter drop-down in Edit Group.

Click the Data tab with the mouse already within the
Business column.
Press Subtotal In Outline Group.
In the resulting submenu, pick the Business from each shift
in a drop-down menu (should be the default).

Ifyou'd like more power about how the data is arranged,
you may apply several layers to some form of data. This
helps you to sort the data in only one column.
Choose a cell in the column that you want to filter through.
In our case, we're going to select cell A2.

Tap the Data tab, and then pick the Sort key.
The Type dialog box would be shown. Choose the first
column that you want to filter through. In this case, we'll
sort T-Shirt Size with a custom list we've previously
generated for the Order area.
Select the Add Level button to add more columns to filter
through.
Pick the next column you would like to sort, then press Yes.
In our case, we're going to sort by Homeroom # (column
A).

The workbook will be ordered according to the sorting style
you desired.



From the Usage feature drop-down, pick Sum.
Review orders in Add subtotal list

Under each business, this function inserts an overview row.
Business A totals 39,000, Company B totals 30,000, and so on. It
was quick.

15.3 Data Filtering
The Data Filter in MS-Excel is a fast way to show only the important
or unique details that we all need and to cover unrelated information
or data in the table momentarily.

In the example below, the Smartphone sales data table
includes a wide list of variables.
First, we need to enable the MS-Excel Data Filter for
Mobile Sale Data Table within MS-Excel, pick the maximum
data set or table range, and then press the Filtering key on
the Data tab on the MS-Excel ribbon. Or press (access
keyboard Control + Shift + L)
As you press Filter, a tiny drop-down key or filtration icon
would be attached to each column in the first row at the
right corner of a cell, i.e.

When Excel detects that the column includes text details,
text filters will be shown automatically. In mobile sales
figures, but I want sales figures in a northern area only,
regardless of the date, commodity, sales rep & unit selling.



16.1 Enable Worksheet Protection
 

CHAPTER 16. Protect Worksheets

16.2 Unlocking Cells Required to Be Modified
 

Enable all worksheet users to be identified, pick elements
that you would like for a person to be allowed to make
changes, and make some modifications.

Choosea Worksheet page thatyou'dlike to cover in your
MS-Excel file.
Right-click somewhere on the sheet and pick Format Cells
(while using Ctrl+1 or Command+1 on Mac) and then go to
the Security tab and select the “locked” option.

Select Protect Sheet from the overview page.

Right-click on the cell or setthatweneedtomodify,anduseFormat
Cells from a menu that emerges.

This will open up the Format Cells panel (the keyboard
shortcut for a window is Ctrl+1). Choose a tab that says
"Protection."
Then, make sure that Locked is checked.

To deter users from unintentionally or purposely modifying,
transferring, or removing data in the worksheet, users may lock cells
on the MS-Excel worksheet instead of encrypting the password layer.



If you want, users will modify a specific cell or range,
uncheck t and Locked box so that even though cells were
also locked by definition, most jobs would be going through
sheets and unlocking cells that users can modify.



Subtract

17.1 Basic Moths in Excel
Sum

 

CHAPTER 17. Basic Arithmetic Functions in
Excel

For instance, the formula below subtracts numbers inside a cell. Just
use the minus symbol (-). Don't miss it. Always begin a formula with
an only equal symbol (=).

In this example, when you put = symbol in cell B2 and then
point the mouse to A2, you need to enter minus symbol
and insert the value you like to remove/subtract from A2;
you would have the above-given result in B2.
The format will be the same if we consider multiplying any
number, and in the case of the division, all you have to do
is just put a division symbol “/” and multiplication symbol “*”

Formulas are considered the foundation of most complex Excel
equations. Excel uses regular formula operators for its calculations,
such as you can use a plus sign for adding (+), a simple minus sign
when you need to subtract the values (-), an asterisk symbol for
multiplication of numbers (*), and the forward-slash symbol for division
(/), you can also use a caret (^) symbol for exponents.

This is normally used to gettheadded result of all values within the
cell selected or in the selected range.
For instance, you want to calculate a total of column D in that case,
follow the steps as given:
Write “=” in D13 or type “sum” after this add “(“and insert a cell
range, i.e., D2-D11 as well as insert “)” now press the enter key .



in the right location.

For division, follow the example given below.

For multiplication, follow the example given below.

The simple percentage rule and the step for measuring the
percentage are given as follows:
(=(part/all) *100)
But what about one percent of that total? Think the following. Suppose
you have shipped your commodity to five regions of the world. You
would like to know which proportion of the overall output is delivered
in each area. See the photo below.

You should position the number mostly on top of that table so that
we wouldn't need to change it whenever you stretch each table. And
it's still clear if the rows are fixed . Now, to measure the percentage of
the overall, write that percent
equation in cell C4, then bring it down:
=B4/B$2.
You're going to see fraction amounts. Now, to translate them to a
number, pick the cells and click CTRL+SHIFT+ (percent). It is a
workaround to translate the amount to the proportion. The same
thing may be achieved in the Number portion of the Home page.

Division

Multiplication

17.2 Complex Equations
Calculating the Percentage for a Total



Go to your home page.
Click on the percent formatting portion of the Number tab.

And it’s almost done at this step .

To start, click on cell B3 to add the Percentage layout to that
same cell. Tap the Percent icon mostly found on the Home
page.
If you are using MS-Excel on the site, press Home >
Number Format > Percentage.
For cell B3, divide that revenue and for the second year
($598,634.00) by its first year ($485,000.00) but instead
deduct 1

This is the formula in cells C3. (B2/A2)-1. The rate of improvement
over the two years becomes 23 percent.
Note the brackets around (B2/A2). MS- Excel next measures what's
in brackets and afterward subtracts 1.

Calculating the Difference in 
Percentage for Two Numbers

Terms of



18.1 Creating a Schedule Using Excel
 

CHAPTER 18. Activating Thousands Separator

1. OpenMicrosoftExcel,presstheFiletab
2. Choose New.
3. On the present Templates screen, 

Schedules icon.
double-click the

The Comma Type Format is classified under the Number Format
portion of the Home tab. The Comma type format is often known as
the Thousand Separator.

In Excel, to show sales numbers by using comma style format:
Choose cells that hold numeric sales figures for which I'd
like to show numbers using a comma-style format.
On the Home tab, in the Number group, you can choose
the Comma mark and press the Comma Style option

This can be done using another method, i.e., when you
select number values, right-click, and choose Format Cells.
Then a window appears. Within this window, move into the
Number segment, select Number below Category, then
click on the "Use 1000 Separator" box and type 2 within
decimal places option & then OK.

You can see adjustments in sales values after clicking the
Comma style. Excel distinguishes the thousands using a
comma and at the end introduces two decimal places. You
will see in the first cell, 7889 will become 7,889.00.
This outcome is shown as follows:



4. Double-click on the File Folder icon containing Business
schedules. Then Double-click on a schedule template that fits
well on your scheduling needs.
5. Press any one of the cells with the hypothetical personnel's

name. Such cells are usually found in the leftmost column.
6. Overtype that hypothetical name with your worker's name.
7. To insert every worker on your schedule, repeat steps five
and six. If you do not need to use all of the rows from the
template, then right-click on the row header of an unwanted
row, and choose Delete. For adding workers, right-click on
the row header, select Insert to attach a blank space, and
then enter the worker's name in the leftmost column.
8. If you haven't inserted or erased any row, you can copy the
cells containing Worker Name. On the next day of the
week, highlight the worker name cells, right-click and
choose Paste, to overwrite hypothetical names with real
workers.
9. Attendance times in many templates provided by Microsoft
Excel, flash on top of schedule chart. If you like, you can
alter the times in such fields merely by overwriting the
existing times.
10. 

Delete all the hypothetical information in the
schedule cells. You may enter a letter X in each cell for the
individual needed to be at the workplace. For instance, to
schedule a worker between 8:00 am. to 05:00 pm., simply
enter X in each corresponding cell.
11. 
The template will include the details just above
the schedule chart that you want to change, like the titles
and areas for the week's beginning or ending date and
perhaps the team's name. You can adjust all this data as
per your wish.



12.
As.
13. 

Now press on the File menu and select Save

Type some name for your schedule, or use the
week number or start or end date as a schedule name.
14. 

Click where you want to file your new schedule.
At last, press the Save key.



19.2 Count Characters in a Cell

19.1 Use of Count-If for Finding Out the
Frequency of Words in a Range

 

CHAPTER 19. Use of Count If Function

The key purpose of the COUNTIFoperationisjust to count how many
times the condition is fulfilled.
The syntax of the COUNTIF operator is "COUNTIF followed by
(range, and a condition)" (omit the bold words from this formula)
Let us relate this feature to a basic illustration of this. Assume we
need to count how many times that the word "Peter" exists in the
sequence A2:A10 like shown below:

Choose the cell you like to type the count in (cell D3 in our
case).
In this selected cell, write the formula: "=COUNTIF(A2:A10,
"Peter")"
Then click the Enter key.
This will show how many times the name "Peter" exists in
the set of cells A2:A10.

Step 1: Open up the Excel spreadsheet holding the
character cells you would like to count.
Step 2: Tap the cell where you want to show the number of
words and symbols in your cell.

Step 3: Write =LEN (XX) but substitute the XX components
of this formula with the cell position you want to count. E.g.,
in the given picture, the formula will be =LEN (A2).



Step 4: Press the Enter key on your keyboard to execute
the formula. You should then see the count of characters
in a target cell.



20.2 Freezing Two Columns
 

do:

20.1 Freeze the First Column
 

20.3 Freezing the Column and Rows

CHAPTER 20. Freezing the Panes for Locking
Rows and Columns

To freezethe firstcolumnof a sheet, press Display tab >
Freeze Panel > "Freeze First Column."
It will render the leftmost column clear at all times when the
sheet is scrolled to the right.

Ifyou'dliketo freezemore than a single column, here is what you'll

Pick the column (or that first cell in that column) to just the
right side of that last column that you'd like to lock.
Go into the Display tab and press Freeze Panels > Freeze
Panels. E.g., if you want to freeze the first two columns,
pick the entire columns C or cell C1, then press Freeze
Panes.

This process will lock the very first two columns into that
place, as shown by that thicker and the darker borders,
allowing you to access cells in that frozen columns as you
pass around the worksheets:



To unlock that frozen rows and columns, go to the Display tab,
community window, and press Freeze panels > Unfreeze panels.

Besides, to lock columns and rows individually, Microsoft Excel
enables you to freeze rows and columns at that same time. Here's
how to:

Pick each cell just below that row and to the right side of
that last column that you want to freeze.
Select Freezing Panes > Freezing Panes on that Display
page.

E.g., to freeze the top row and the first column in that single move,
choose cell B2 and press Freeze panels:

This process will make the headers row, as well as the
leftmost columns of that table, would still be clear when you
scrolled down and also to the right side

20.4 Un-Freeze Rows and Column



CHAPTER 21. Convert Your SCV or TXT File and
Open It Into an Excel Sheet

Delete all of the checkboxes under that Delimiters, except
that Tab check box, and press Next.

Select the End tab.

For CSV File, Click that File tab, and click the Open icon.
Click the CSV file that you want to access. Microsoft Excel
immediately opens a text file that shows the details in that
new workbook

It is the most straightforward (and quickest) way to open the CSV
file.MS- Excel uses that default data format setting that interprets
and then imports data columns. The automated import does not,
however, give you the versatility you desire.
For Txt File, just follow the given steps to import text data.

Press Open on that File page.
Select the Browse tab.

Choose Text Files from a drop-down column.

To import that CSV file, pick the MS-Excel Comma
Separated File and then press Open. That's all of it.
To import the text format, pick the Text file and press open.
MS- Excel can open its Text Import Wizard.
Select Delimited and then press next.



TXT

CSV

21.1 Difference Between TXT CSV and XLS Files
XLS

 

.txt is the text file extension that is used for data collection.
That file format comprises plain text, either bold or italic.
Such files can be quickly accessed and read into any text
support software.

An Xls format is the one that notonlyholds datavalues but
can also do some data values activity.
The xls format is the spreadsheet sheet that holds all data
values on its own, the proprietary formats, viz xlsformat and
the xlsformat.
None of the text editors can open or modify Xls stored into
MS-Excel.

CSV format holds data values and does not include
encoding, algorithms, help macros, respectively, and are
often known as flat files.
That CSV format is for data saving tabular detail data in the
delimited plain text files with a .csv extension.
The CSV format may also be open to all modified text
editors, including notepad or sublime.



22.1 Use of Fill Handle for Copying Formatting
 

CHAPTER 22. Advanced Formatting Options in
Excel

22.2 Use of Paste Option for Copying Formatting
 Another easy way to copy that format to MS-Excel is to usethe

keyboard shortcuts for the Paste Special > Formats:
Pick the cells from which you like the format to be copied.
To copy that chosen cells to the clipboard, click Ctrl + C.
Pick the cell(s) where the format must be used.
Tap Shift + F10, S, R in MS-Excel 2010-2019, and then tap

Thefillinghandle functions in combination withthemouse.Fillingthe
handle uses include:

Copying and formatting details
Copying of formulas
Fill the cells with a variety of numbers, like odd and even
numbers, and several more.

Highlight the cell(s) containing the data to be copied or extended in
the case of a series. Place the mouse pointer over the fill handle.
The pointer changes to a small black plus sign (+).

Highlight that cell(s) holding that data to be copied and
expanded in that case of a sequence.
Place a mouse pointer over that filling handle. The pointer
switches to a tiny black plus (+) symbol.

Click and holding down that left mouse button icon; drag the fill
handle to the desired cell (s).



Enter.

Let suppose you may have codes that consist of five digits. Instead
of form 00041, only type 41 and then let MS-Excel adding the
leading zeros.

Creating the MS-Excel format style would save a lot of time,
particularly if you would have various custom formatting specifications. You may assume that you need to re-create
these types for each workbook, but you do not. If you would establish
that style, you could copy it to another workbook—you do not have to
go through the hassle of re-creating that style into the workbook files.
Here's how to clone the style:

Open all workbooks—a source workbook that incorporates
the pattern and the target workbook you intend to copy a
style.
Choose Design from the Shape menu in a Destination
Workbook.
Only press Combine.
Choose a workbook that includes that current style(s) you
wish to duplicate in a corresponding Merge Style dialog
box.
Double click OK.
Look on the Home page icon, press Cell Style in that Styles
Group. Merge Style is situated at the bottom of the
resultant pane.

At this stage, a destination workbook includes all of the custom
styles of that source workbook and then starts formatting!
22.4 Create Your Custom Format for Data That Is

22.3 Copying Style Between the Workbook

Readable



Join a value of 41 in cell A1.
Pick cell A1, right-click, then tap Cell Format.
Choose Tradition.
Type in the following numbers format code: 00000

Select the OK tab

You may also add the theme to the cell or the sequence of the cells.
There are many default cell types in MS-Excel.

To add a basic cell style:
Pick the cell(s) you want to format.
Tap on the required cell styles. That Two cells would have
the styles added in that screenshot below.
"Good" cell means that data in that cell is either good or
correct.
The "Check" cell means you will need to validate the detail
in that cell.

22.5 Creating Cell Style Indicating a Purpose



23.2 Putting Page Break
 

23.1 Verifying Page Orientation
In excel, Page orientation applies to how the production of the page
is written. If you alter that orientation, it will immediately switch to the
current paper orientation on page breaks. To check the orientation of
that page:

CHAPTER 23. How to Solve Your Common
Printing Issues

Go to the Style tab of the website and then to the
orientation portion.
When you tap on the orientation tab, you can see the drop-
down of two portrait and landscape choices, which are
already selected and highlighted. See the illustration below
where the image is already
picked, which implies that the direction of your existing
document is now a portrait.

To access theboundary and region control mode, you have to go to
that "VIEW" tab and pick that "Page Break Preview" method in the
Workbook Views portion.

The second choice is to press on the third switch on the
MS-Excel pane status bar's right side.
You have to set and correct page layout borders that will
divide all areas to identify a print area. In doing this, press
the blue dotted lines into the Page Break Preview display
and shift it to the appropriate location, holding down a left
mouse button Icon.



Choose the File page. The backstage view will be shown

Choose Print. The Print panel will be shown.

And you'll see your preview just on the right side of a
window that can be changed according to your needs.

You may use the following to arrange a printing area. The latest
page orientation would be shown in the Overview panel.

Navigate to a Print panel. In our case, we can observe in
the Preview panel that our material will cut off when it is

If a table reaches past the white field, anything in the gray
area would not have written. If you are in the Page Split
Preview display and all that data is in the gray field, you
can get a blank paper while printing. You may delete a
print region manually by dragging this boundary between
both the gray and white areas.
Define the print field, set the boundary, and change it. How
do I apply boundaries (page breaks)? Press on a cell
where the database break must be placed and select the
alternative "Insert Page Break."

In what way can we incorporate the vertical page break?
Right-click on a column where a border is to be placed,
select the identical option: "Insert Page-Break." To insert
the horizontal page split, you can do the same thing—click
on a header of a certain row.

Note. A “Reset Print Area" choice is available in a context
menu. It enables you to remove all text breaks and change
the default settings. Use this to start over again.

23.3 How to View the Preview Option



Select somewhere on the worksheet where you'd like to clear the

printed. From the Page Orientation drop-down panel, choose
the
appropriate orientation. In our Instance, we're going to
choose Landscape Orientation.

The updated page orientation will now be shown in the
Overview panel.

Simply Navigate for the Print panel. In our case, we can
easily see in our Preview panel that our whole content is
shown as cut off when it is printed.

Make a selection of your own choice from the dropdown
menu used for Scaling. In our example, we have selected
the Fit All Columns option from the drop-down list.

The workbook will be simplified to fit onto the single tab.

Pick the number of cells you'd like to set as a print region in
the MS-Excel worksheet.
Go to Web Configuration -> Web Setup -> Display Region -
> Print Area Setup.
It will set all the selected cells to the print region and will
create a named set for the chosen region as well.

To Clear the Area

23.4 Set or Clear the Print Area for Your
Spreadsheet

To Set the Area



printing regions.
Go to Web Configuration –> Web Setup –> Print Field –> Print Area.



24.2 Copying Your Worksheet Within Your
Workbook

 

24.1 Moving Your Worksheet Within the Same
Workbook

 

CHAPTER 24. How to Move & Copy Your
Worksheet Data

Ifyouwant to copy a certainWorksheet, copying all that Worksheet
contents to the current Worksheet follows the measures below.

Right-click a Worksheet tab you would like to copy at the
bottom of the MS-Excel pane.
Select the move button or Icon for Copy.
In a Move or Copy pane, pick that Worksheet where you'd

Ifyou always have moved the sheet from one workbook to another,
you might have used a right-click menu Icon to pick Transfer or
Duplicate. But you will simply drag and drop a sheet directly to some
other spot within or outside of the workbook.

Only click on a tab that has the name of a sheet on it.
Next, hold a mouse button icon down as you drag that
mouseover.
And then drop it anywhere you wish it to be in the latest
workbook.

This method transfers the sheet entirely and does not leave a
duplicate copy in the "from" workbook. Although, if you wish to leave
a sheet and create a duplicate of it on a new sheet, the procedure is
just as simple.



like to put the copied Worksheet in the before sheet
column.
Check a Create Copy choice window, then press OK

A worksheet duplicate is inserted and positioned before a Worksheet
that you choose in step three above. E.g., if you have two
worksheets known as "Sheet1" and "Sheet2," you choose Sheet2 in
Process 3, other copies of Sheet2 will be put in place of Sheet1. The
outcome will look like an image of the illustration below. That
"Sheet2 (2)" Workbook is the clone of Sheet2.



25.1 How Relational Database Functions
The hierarchical framework of MS-Excel lends itself very well to how
the databases function. The database is a list of linked objects
(spreadsheet) that, once associated, generates a particular
document (row) inside a set of multiple records (table). Each
spreadsheet, on its own, is the database, but not a hierarchical one.
To sum up, in simple words, we can say that a relational database is
the mixture of a Master spreadsheet table and its subordinate tables,
including word documents.
25.2 Relational Database and Its Applications
Relational databases are designed to understand the association
between already stored knowledge objects in data. This allows you to
easily retrieve and scan for relevant details, display the same data
collection in several forms, and minimize data errors and redundancy.
There have been a variety of explanations for building relational
databases. Its most noticeable features are that you don't duplicate
the same details on your workbook spreadsheet. E.g., it is repetitive,
extremely time taking to copy and paste every driver's name and
birth date from a Master database to several Slave databases. But
even though you copy the details from one to the next, it also
consumes unnecessary storage space and memory, slowing it down.
Often, a name and date of birth are not special. For example,
hundreds of Jack Scott, John Smiths, or any of them may easily
share their same birthplace. You're only using a license plate. You
can't distinguish the drivers. Then you're required (to be secure) to
use almost all three fields
Our key purpose for relational databases should be to build queries
and indexes that really can retrieve and print unique details. Maybe

CHAPTER 25. Creating a Database Using an
Excel Spreadsheet



A database is normally known as the data stored in a spreadsheet in
rows and columns for fast browsing, sorting, and editing. But how can
you render a database in MS-Excel?
Any material in a report is stored in the following field and records:

Record is the database (DB) line that contains details
regarding a specific entity.
The field is Indeed the column in the database holding the
same sort of knowledge for all items.
Records and archive areas are both the lines and the
columns of the regular MS- Excel spreadsheet.

your supervisor needs a survey that reveals someone in Santa Rosa
City, Florida, with traffic violations above $300, or even how many
Pensacola riders had new license dates in December? Without a
relational database ability, you'd have had to copy and paste the
details together through three or more word documents to that fourth
spreadsheet and keep hoping you're all done, and your supervisor
doesn't claim, "We say Sarasota County, never Santa Rosa County."
25.3 A Simple Example of the Database

To remind you about how well that MS-Excel database functions, we'll
explore two tables—a master table and an information table. The main
table is the one that usually includes critical data. This table scarcely
updates unless, say, to introduce or remove entities .
With any record in a master table, several records in the information
tables (also known as slave or infant tables) connect all to the
master table. It's considered a one-to-many friendship. The data
throughout the comprehensive tables—such as regular revenue,
product values, or quantity—often fluctuate continuously. To stop
repeating all of the master details in each detail chart, build a
partnership using a single area, including the Sales ID, and then let

25.4 What Is Meant by a Master Database



Tap somewhere in the data range and tap the Insert button.
Tap on the table in the group of tables. Tap quite well in that
resulting dialog box displayed in the
figure below. That header choice is already tested in this
situation. When implementing that technique to your very
own results, you may also want to test or uncheck this
choice properly.

Tap inside that table and tap the Interface background key. Then
type the meaningful name in that named area of the table, as seen in
that figure below. Call that Daily Totals Table as well as that Sites
Table .

The figure below displays two sheets of relevant details. As you'll
see, any record in Regular Totals includes a meaning that is further
explained by date, staff, and city. Site documents show the cities
from each country. Today, assume you would like to total those
values by area for Everyday Totals.
Working with the information won't always be that easy. I have
maintainintentionally kept this example straightforward to 
concentration mostly on steps .

MS-Excel do the rest. For, e.g., you have ten sales staff who all have
specific demographic details (main table). Any sales individual has
200 items that the employee is selling (detailed and child table). Only
at the end of every year, you need the report detailing the overall
annual sales by the individual, but you'll need that report outlining the
overall sales by region.
25.5 Creating a Database in Excel Along With the

Converting Data to the Tables

Use of Filters



There are no geographic details in the data collection that includes
the values you would like to outline. This isn't an issue with data
modeling. What you need now is a connection between the tables
and the values you want to analyze and the geographical
information you can use to analyze such principles.

First of all, press the Data tab. Even in the Data Tools
category, tap Relationships. (If this
alternative is dimmed, go back to #2 and build a table.)
Select Daily Total Table from that first table dropdown.
Select "City" into that Column (Foreign) dropdown.
Select "Site Table" in that Linked Table drop-down.
Select “City" as seen in Figure D in that Linked Columns
(Primary) drop-down.
Select the OK tab.
Select close to move back to that sheet.

Specify each column that perhaps the columns share to
create a relationship inside those two tables.
We can create another Pivot Table to describe the values.
Tap the Total Daily Table in and select the Insert key. Select
Pivot Table throughout the Tables group, as MS-Excel
presents the dialog seen in Figure E, press OK.

At this stage, the pivot Tables framework presently tests one more
table, Daily Total Tables. Add Site Table to the following:

Tap the connection and MORE TABLES.
Press Enter in that resulting dialog. Doing so requires a
modern data modeling functionality.
As you'll see in the following image, both tables also are

Creating the Relations



part of the layout of the pivot table.

.
Now information models function will be enabled by clicking on
Further TABLE S

It is indeed time to start incorporating the Pivot Table areas. Next,
press the Extend arrow to that left of the Daily Total Table to access
its fields. Check for Importance and City. Using the scroll bar to
navigate the Site Table.

That data modeling function helps you to connect features from both
the table to that Pivot Table frame.
That Pivot Table definitely won't be flawless at this stage, but it's time
to begin adjusting a bit. The figure indicates the effect of pulling that
region field to that COLUMNS segment.

If you don't like this style, you can easily swap column and line
headers. Drag that City field to that COLUMNS portion and the Area
field to that ROWS section, as seen in the figure.

When you pay careful attention, you may have seen the (blank)
lines. Can you guess and tell where these lines are originated? One
can easily diagnose a problem arising by the question or analyzing
those community headers for certain products. Use the figure given
below. You will decide that there is no area of importance for Boston
but Cleveland. Luckily, this is a quick fix. See below, adding the
values to a Table.

Reload that Pivot Table after introducing new regional documents. To
do so, tap inside that table and then tap the Analyze context menu.

Adding the Fields



In that Data Group, tap the Refresh button .

From this step, you can even filter the required cities by tapping on a
filter option with an arrow at the top row with the name "city" and
selecting that desired city with filters. If you wouldn't want to use the
filters and see all that results, start deleting your selection and choose
the "select all" choice.

By refreshing your pivot, the regional values would be shown
correctly.
Do you see that little magnifying glass symbol in that figure above?
Pressing that will help you drill further into the information which is
not currently available. Tapping this icon with that value of the
chosen Cleveland will show the dialog .

That dialog is set to the Sites Table by default; however, you may
switch to Daily Total Table.

Filters Options



26.1 Input Masks
The input mask is commonly considered a type of variable illustrating
the correct input values' format. You may use the input masks in table
areas, question fields, and type or the report controls. That

 

Input Mask Has Three Important Parts
 

CHAPTER 26. Data Entry Using the Input Masks

entry mask is maintained as anentity resource.

Input-mask is made up of one mandatorycomponent and two
optional sections, so each component is divided by a semicolon. The
goal of each part is just given below:

The very first element of this is necessary. It contains mask
symbols or strings (sequence of characters) together with

brackets,placeholders and specific details such as 
intervals, and hyphens.
That second section is optional and applies to that
embedded masks characters and how they've been stored
in the region. If the second component is set to 0, that
characters are recorded with the details, and if they are
adjusted to 1, those symbols are only displayed but not
saved. Set that second part to 1 will save the storage
capacity of the server.
The third component of that input mask is optional and
shows a specific individual or space using it as a buffer.
Access uses that underscore (_) by default settings. If you
choose to use a new character, insert this in the third
portion of your masks.

Suppose it is an input mask for phone numbers in the U.S. format:
(999) 000-000;0; -:



The following information describes the placeholder and the specific
characters for the input masks and demonstrates how to monitor the
data entry.

0: The client is expected to insert a bit from (0 to 9).
9: The consumer is required to insert a digit from (0 to 9).
#: The consumer can insert an integer, space, plus, or
minus symbol. If missed, the submission comes to avoid
the space.
L: The consumer is expected to insert a letter. You may
enter a letter.
C: The consumer is permitted to access characters or
gaps.
;-/: Decimal and thousands of placeholders, date, and
period separators.
That character you choose depends on certain sets in MS
Windows.
<: Includes all characters that are accompanied by the
upper case.
<: Translates all of the characters that proceed to
lowercase. This allows the input mask to be filled with the
left to right rather than from left to right.

That mask has two placeholder elements, 9 and 0. That 9
indicates an available digit (which allows it easier to reach
an area code), so each 0 indicates a required digit.
The 0 in that second part of that input masks indicate that
mask characters are stored along with that info.
The third portion of that input mask states that the hyphen
(-) should be used as the replacement character instead of
that underscore (_).

Characters That Define the Input Masks



\: Directly follows those characters which are shown
exactly.
": Characters contained in double quote marks would be
shown exactly.

You will use the so-called Input Mask to establish input masks in
Microsoft access 2016, including future iterations, i.e., 2019. That
input mask is a sequence of basic rules that determine the type for
which that data should be submitted in a sector.
For, e.g., an input mask of (999) 000-0000 may be used to decide
how telephone numbers are inserted. In this case, that area code is
mandatory, but its numbers must be entered. The explanation for
that is because, with every input mask, a 9 defines an obligatory
number, a 0 defines a required number.
We can now add an embedding layer to that Release Date area in
our Albums chart. Our input mask would ensure that users insert that
official date of every other album in that proper format.

Enable the design chart.
Tap the Release Date area for that purpose; see the given
photo. The bottom frame shows the properties for this area.
Tap on the Input Masks row in the bottom frame. There

As helpful as they are, input masks aren't helpful in all situations. If
the following conditions applied to anyone, you should not use an
input mask:

Whenever people need to insert data that does not fit the
mask, the input mask doesn't make exceptions.
You're planning to use a Date Picker controller with a Date
or Time field. Input masks aren't compliant with the Date
Picker controller.

26.2 Avoid the Use of Input Masks

26.3 Add an Input Mask Using Mask Wizard



would be a tiny icon with the three dots. That Input Mask
Wizard activates by using the wizard.
Press on a little [...] tab with three dots

The Input Wizard Mask provides several choices on
whatever you want that data to be processed. You can pick
any alternative and evaluate this at the lower of that wizard
throughout the Try It area.
Choose the Medium Date and press Next.

The next display lets you make changes to that input mask. You
could evaluate any configurations in that Try It area at the bottom of
the wizard.

We're going to add one small change.
Connect two zeros to render the input mask: 99->L<LLL-
0000
This means that the consumer enters that date with DD-
MMM-YYYY. 20-Mar-2016, for instance.
When you're satisfied with your feedback mask, press
Next.

Input Mask Wizard should display you the last display; if
not, press the End or Finish button.

When that Input Mask Wizard is closed, you can see the freshly
generated Interface Masks having Input Masks property into Project
Folder.

26.4 Adding Input Mask for a Query or Report
For Query



First, you must build a blank form or update a current form
to include your custom input mask.
The Input masks may only be applied to the text region of
the single line.
Now drag and drop the text for a single line.
Then after dragging, select the form field to access the

Right-click the data you want to adjust from your navigation
window and tap the Design display menu, mostly on the
menu bar.
Hold the cursor in that column for the area you wish to
switch into that database interface grid. You may also hold
the cursor to every row in that sector. Click F4 to access that
field's property document. In that Field Properties list, press
the Feedback Mask
properties box on a General tab.
Now press the Create key to open your Input Mask Wizard,
and follow the directions closely in the details already
given.

In the Navigation Pane, make a right-click to the form or the
report you need to change and click design view on the
shortcut menu.
Make a right-click to the Control that you want to change.
After then click on the Properties option on the shortcut
menu.
On the All tab, tap on the Input Mask property box.
To start the input mask wizard, hit the Build button and
carefully follow the wizard's instructions.

For Reporting

26.5 Creating Customized Input Mask



The field inside a table is referred to as a column. It represents a
fixed attribute for the records inside a table. A User can add a
total of 225 fields to a single table. Each field you add in the table
contains various features that offer you some additional control
over your results. Here's a tutorial on how to set the field in a
table: On the Home ribbon, select "View" and then choose

"Design View."
Now, you'll be prompted to modify the title of the table.
Enter the title.
When you pick a sector, the properties box will emerge on
the bottom part of the table design view.
Select the Field Layout to modify your data and adjust the
direction it is viewed on the computer or when you record
your data.

Field Options box.
Go to forwarding Choice in the field option. You will see the
Input Mask options in the Advanced field tab.
You should mask the input from this step now.
For example, if you need an 8-digit number, you can insert
8 9's in your Input Mask area.
When the form becomes visible on the web, an underscore
sign will be displayed to users for each appropriate digit.
In this example, we have used “9,” so only numeric values
are allowed.

Take the example. U.S. zip codes have a 4-digits suffix that many
people do not consider. Hence, we do not want it. Therefore, we will

26.7 Input Masks Examples

26.6 Customizing the Input Masks Using the Field
Property Settings



use the "9" character for making this data optional.

From an open table, select the "View" from the Ribbon section
navigate to the "Design View." At this stage, all the validation rules
should be cleared in the properties field of your table. Those are not
visible in the "Datasheet View." tab.

26.8 Using Input Mask Specifically for an Email
Address
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